Bug 445337 - Negotiate support
Negotiate support
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: squid (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Martin Nagy
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-06 05:11 EDT by Charles Lopes
Modified: 2016-07-26 19:46 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 516245 (view as bug list)
Environment:
Last Closed: 2008-05-14 13:01:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Charles Lopes 2008-05-06 05:11:46 EDT
Can you please enable the support for negotiate authentication in squid and the
build of the kerberos negotiate authentication helper? The only change needed in
the spec file is the addition of a couple configure options:

--- SPECS/squid.spec    2007-12-21 10:52:21.000000000 +0100
+++ SPECS/squid.spec    2007-12-21 10:52:21.000000000 +0100
@@ -85,7 +85,8 @@
    --with-pthreads \
    --enable-ntlm-auth-helpers="SMB,fakeauth" \
    --enable-external-acl-helpers="ip_user,ldap_group,unix_group,wbinfo_group" \
-   --enable-auth="basic,digest,ntlm" \
+   --enable-auth="basic,digest,ntlm,negotiate" \
+   --enable-negotiate-auth-helpers="squid_kerb_auth" \
    --enable-digest-auth-helpers="password" \
    --with-winbind-auth-challenge \
    --enable-useragent-log \
Comment 1 Fedora Update System 2008-05-07 12:44:59 EDT
squid-2.6.STABLE20-2.fc8 has been submitted as an update for Fedora 8
Comment 2 Martin Nagy 2008-05-07 12:49:01 EDT
I submitted the update. If you'd like to help with testing, you can install the
testing version and provide feedback at
http://admin.fedoraproject.org/updates/F8/pending/squid-2.6.STABLE20-2.fc8
Don't forget to check "Works for me". Thanks.
Comment 3 Martin Nagy 2008-05-09 07:06:34 EDT
I also fixed this in squid-3.0.STABLE5-2.fc10
Comment 4 Fedora Update System 2008-05-10 09:52:42 EDT
squid-2.6.STABLE20-2.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update squid'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F8/FEDORA-2008-3530

Note You need to log in before you can comment on or make changes to this bug.