Bug 445391 - yum install of xulrunner w/o firefox has file conflicts
yum install of xulrunner w/o firefox has file conflicts
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: firefox (Show other bugs)
5.2
All Linux
urgent Severity low
: rc
: ---
Assigned To: Gecko Maintainer
desktop-bugs@redhat.com
: Desktop
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-06 13:01 EDT by Suzanne Hillman
Modified: 2010-03-14 17:28 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-17 11:16:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Suzanne Hillman 2008-05-06 13:01:20 EDT
Description of problem:
yum install of xulrunner w/o firefox has file conflicts. This is a problem when
dealing with packages with a dependancy on xulrunner, because yum won't complain
until rpm fails.

Version-Release number of selected component (if applicable):
xulrunner-1.9-0.beta5.4.el5

How reproducible:
Always

Steps to Reproduce:
1. Try to intsall xulrunner via yum. (or try to run RNHQA for gnome-python2-extras)
  
Actual results:
Yum does not complain until rpm fails.

Expected results:
Yum should figure it out and either tell you why it failed before trying to
download files, or grab new firefox, too.

Additional info:
Comment 1 Matěj Cepl 2008-05-06 14:43:49 EDT
Suzanne, could you copy&paste exact error message you get when trying to install
xulrunner, please?

Thank you.
Comment 2 Suzanne Hillman 2008-05-06 15:23:36 EDT
[root@dhcp-100-2-166 ~]# yum -y install xulrunner
Loading "security" plugin
Loading "rhnplugin" plugin
There was an error communicating with RHN.
RHN support will be disabled.
Error communicating with server. The message was:
Not Found
Setting up Install Process
Parsing package install arguments
Resolving Dependencies
--> Running transaction check
---> Package xulrunner.i386 0:1.9-0.beta5.4.el5 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

=============================================================================
 Package                 Arch       Version          Repository        Size 
=============================================================================
Installing:
 xulrunner               i386       1.9-0.beta5.4.el5  Client            9.9 M

Transaction Summary
=============================================================================
Install      1 Package(s)         
Update       0 Package(s)         
Remove       0 Package(s)         

Total download size: 9.9 M
Downloading Packages:
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test


Transaction Check Error:
  file /etc/gre.d/gre.conf from install of xulrunner-1.9-0.beta5.4.el5 conflicts
with file from package firefox-1.5.0.12-15.el5_1

Error Summary
-------------

(note: This is with 5.2's yum, yum-3.2.8-9.el5)
Comment 3 Christopher Aillon 2008-05-06 17:02:58 EDT
I think the best way to fix this is probably to add Requires: gecko-libs =
1.8.1.x to the old package, so it will notice there's a dependency upgrade in
the libaries and firefox will also get upgraded...
Comment 4 Suzanne Hillman 2008-05-07 10:35:39 EDT
caillon: That won't have any useful effect, because the problem is only with
people who already _have_ the old package.

How likely would it be that causing both firefox & xulrunner to obsolete the old
firefox would fix it? Would that mean installing xulrunner (w/o firefox) would
remove the old firefox?

I don't know! I don't know if it's more important to a) allow xulrunner to be
installable without firefox, or b) to keep a browser on the system at all times
if one was there. In the case where it was _not_ there, the problem won't arise. 
Comment 5 Christopher Aillon 2008-05-08 18:04:16 EDT
Well, the problem is that this error is occuring because the Requires SHOULD
have been there but wasn't.  We should issue an ASYNC in 5.1 and have people
update to that BEFORE upgrading to 5.2.  AFAIK, all upgrades SHOULD be done on
an updated system, anyway, no?

AFAICS, there's no way we can fix the upgrade if we don't do what I suggested in
comment 3 (and this one).
Comment 6 Zack Cerza 2008-05-13 14:23:42 EDT
Hmm. Well, nspluginwrapper requires gecko-libs = 1.9, and I think I'm seeing the
same problem.
Comment 7 Zack Cerza 2008-05-13 14:26:20 EDT
Ignore that last comment, I was thinking this was assigned to a different package.
Comment 8 James Antill 2008-05-13 17:05:02 EDT
 So I'm pretty[1] sure we can have:

conflicts: firefox < 3.0-0.beta5.3.el5

...in the xulrunner package, which yum will then use as information to upgrade
firefox if xulrunner is installed.

[1] i.e. please test it before you push the zero day errata :)
Comment 17 RHEL Product and Program Management 2008-06-02 16:01:53 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 19 Martin Stransky 2008-07-17 09:26:55 EDT
IMHO desn't make much sense to fix this bug in rhel‑5.3.0 when it should be
already fixed by updating to rhel‑5.2.
Comment 20 Ryan Lerch 2008-08-11 23:42:07 EDT
Tracking this bug for the Red Hat Enterprise Linux 5.3 Release Notes.
Comment 25 Martin Stransky 2008-11-17 11:16:55 EST
Already fixed in 3.0.4.

Note You need to log in before you can comment on or make changes to this bug.