Bug 445423 - hdf5 long double tests fail on ppc64
hdf5 long double tests fail on ppc64
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: hdf5 (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Orion Poplawski
Fedora Extras Quality Assurance
: Tracking
Depends On:
Blocks: FE-ExcludeArch-ppc64/F-ExcludeArch-ppc64
  Show dependency treegraph
 
Reported: 2008-05-06 15:55 EDT by Orion Poplawski
Modified: 2011-11-22 17:20 EST (History)
1 user (show)

See Also:
Fixed In Version: hdf5-1.8.7-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-11-22 17:20:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Orion Poplawski 2008-05-06 15:55:00 EDT
See http://koji.fedoraproject.org/koji/getfile?taskID=596775&name=build.log

Can remove some of the failures by changing CFLAGS to "-m64", but not all:

Testing soft normalized long double -> long conversions               *FAILED*
Testing soft normalized long double -> unsigned long conversions      *FAILED*
Testing soft long -> long double conversions                          *FAILED*
Testing soft unsigned long -> long double conversions                 *FAILED*
Comment 1 Orion Poplawski 2008-05-06 16:16:34 EDT
-fno-strict-aliasing doesn't help.
Comment 2 Kevin Kofler 2008-05-09 11:51:06 EDT
Why don't you just %ifnarch ppc64 the call to make check?
Comment 3 Orion Poplawski 2008-05-09 12:12:40 EDT
Well, I rather not ship a broken library.  I'm still in communication with
upstream.  Looks like long double support may be considered experimental at this
point, so I may disable the check on ppc64 for now.
Comment 4 Orion Poplawski 2008-11-15 21:55:53 EST
Shipping hdf5 on pp64 with tests disabled.  Keep testing new releases to see if this gets fixed.

Note You need to log in before you can comment on or make changes to this bug.