Bug 445452 - gpk-install-package doesn't prompt for GPG key import
gpk-install-package doesn't prompt for GPG key import
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: gnome-packagekit (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Robin Norwood
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-06 17:33 EDT by Owen Taylor
Modified: 2008-05-22 12:53 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-22 12:53:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Owen Taylor 2008-05-06 17:33:00 EDT
If you don't have the Fedora key installed and you run g

 gpk-install-package <something in fedora repo>

You get an error dialog saying that the GPG key was missing, rather than a
prompt to actually import the key. gpk-application works fine.
Comment 1 Richard Hughes 2008-05-07 13:01:33 EDT
This is fixed properly in 0.2.0 -- do you want me to bodge it like I did for
gpk-application or just wait for me to ship 0.2.x in F9?
Comment 2 Owen Taylor 2008-05-07 14:34:57 EDT
I think that's a larger discussion ... do we do a bug-fix-only upgrade 0-day
or shortly after F9, or do we upgrade F9 to 0.2.x. I guess we can discuss
that on Friday.

It's not immediately critical for me since we import the fedora PGP key
when setting up live CDs.
Comment 3 Bug Zapper 2008-05-14 06:44:23 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 Richard Hughes 2008-05-22 12:53:30 EDT
Okay, I bodged it in, although it's much more slick in 0.2.x.

Note You need to log in before you can comment on or make changes to this bug.