Bug 445472 - fix problems in xen/ia64 domain resume
fix problems in xen/ia64 domain resume
Status: CLOSED DUPLICATE of bug 288511
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel-xen (Show other bugs)
5.2
ia64 Linux
low Severity low
: rc
: ---
Assigned To: Xen Maintainance List
Martin Jenner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-06 20:12 EDT by Aron Griffis
Modified: 2009-01-22 09:03 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-22 09:03:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
backport of xen-unstable.hg 204046d99562 and 1a010d9444ba (2.02 KB, patch)
2008-05-06 20:23 EDT, Aron Griffis
no flags Details | Diff
ia64 fix time resume (3.43 KB, patch)
2009-01-15 04:54 EST, Chris Lalancette
no flags Details | Diff

  None (edit)
Description Aron Griffis 2008-05-06 20:12:55 EDT
Description of problem:
Two upstream xen/ia64 patches were inadvertently left behind in RHEL5.x:

http://xenbits.xensource.com/xen-unstable.hg?rev/204046d99562
-- adds missing locking
-- initialize missing ticks for steal time accounting on resume

http://xenbits.xensource.com/xen-unstable.hg?rev/1a010d9444ba
-- avoid soft lockup when domain is resumed

Both of these should be fixed in RHEL, so I've ported the patches, tested them
and will attach them to this bug.

Version-Release number of selected component (if applicable):
kernel-2.6.18-91.el5.ia64.rpm
(and all prior RHEL5 xen/ia64 kernels)
Comment 1 Aron Griffis 2008-05-06 20:23:11 EDT
Created attachment 304706 [details]
backport of xen-unstable.hg 204046d99562 and 1a010d9444ba

This patch is simpler than the original changesets.  Changeset 204046d99562
includes a large block of code that runs optionally if
xen_ia64_settimefoday_after_resume is passed on the kernel command-line. 
That's superfluous to the fix so omitted from the port.  The same changeset
includes a large chunk of code that's commented out with #if 0, also omitted
from the port.
Comment 2 Chris Lalancette 2009-01-15 04:54:48 EST
Created attachment 329076 [details]
ia64 fix time resume

Your alternate patch may be simpler, but we like to stay close to upstream where possible.  That just makes it easier for us to port additional fixes in the future.  I've attached a new patch which is basically the two upstream c/s combined; this should be a pretty faithful backport.  Can you give this a once over to make sure it is sane?

Thanks,
Chris Lalancette
Comment 3 Chris Lalancette 2009-01-15 09:46:02 EST
I've uploaded a test kernel that contains this fix (along with several others)
to this location:

http://people.redhat.com/clalance/virttest

Could the original reporter try out the test kernels there, and report back if
it fixes the problem?

Thanks,
Chris Lalancette
Comment 4 Chris Lalancette 2009-01-22 09:03:25 EST
Actually, while going back through BZ's, I've found that this is basically a
dup of 288511.  Closing it as such.

Chris Lalancette

*** This bug has been marked as a duplicate of bug 288511 ***

Note You need to log in before you can comment on or make changes to this bug.