Bug 445494 - gcc: Internal error: Segmentation fault
gcc: Internal error: Segmentation fault
Status: CLOSED DUPLICATE of bug 440139
Product: Fedora
Classification: Fedora
Component: gcc (Show other bugs)
9
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-07 03:20 EDT by Trevor Davenport
Modified: 2008-05-29 12:54 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-29 12:54:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Trevor Davenport 2008-05-07 03:20:23 EDT
Compiling wine (commit id d2364d5d27d91ac723fdec86120fa95d3d4536a4) dies
building wine/dlls/user32/tests with :
gcc -c -I. -I. -I../../../include -I../../../include   -D_REENTRANT -fPIC -Wall
-pipe -fno-strict-aliasing -Wdeclaration-after-statement -Wwrite-strings
-Wtype-limits -Wpointer-arith  -g -O2  -o menu.o menu.c
{standard input}: Assembler messages:
{standard input}:7412: Warning: end of file not at end of a line; newline inserted
{standard input}:7745: Error: unknown pseudo-op: `.l'
gcc: Internal error: Segmentation fault (program cc1)
Please submit a full bug report.
See <http://bugzilla.redhat.com/bugzilla> for instructions.
make[2]: *** [menu.o] Error 1


rpm -q gcc
gcc-4.3.0-8.i386
Comment 1 sinatosk 2008-05-10 07:19:16 EDT
I too have this problem... sorry if I sound verbose :p... new to Linux

http://forums.fedoraforum.org/showpost.php?p=1008188&postcount=1
Comment 2 Bug Zapper 2008-05-14 06:45:09 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 Thomas Gordon 2008-05-15 02:17:18 EDT
I get the same on F9 with F8 xorg-x11 compiling f8 and f9 wine rpms for i386 on
x86_64/gcc-4.3.0-8.x86_64.


gcc -m32 -c -I. -I. -I../../../include -I../../../include   -D_REENTRANT -fPIC
-Wall -pipe -fno-strict-aliasing -Wdeclaration-after-statement -Wwrite-strings
-Wtype-limits -Wpointer-arith  -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2
-fexceptions -fstack-protector --param=ssp-buffer-size=4 -m32 -march=i386
-mtune=generic -fasynchronous-unwind-tables  -o menu.o menu.c
{standard input}: Assembler messages:
{standard input}:7524: Warning: end of file not at end of a line; newline inserted
gcc: Internal error: Segmentation fault (program cc1)
Please submit a full bug report.
See <http://bugzilla.redhat.com/bugzilla> for instructions.
make[2]: *** [menu.o] Error 1
make[2]: Leaving directory `/usr/src/redhat/BUILD/wine-0.9.58-fe/dlls/user32/tests'
make[1]: *** [user32/tests] Error 2
make[1]: Leaving directory `/usr/src/redhat/BUILD/wine-0.9.58-fe/dlls'
make: *** [dlls] Error 2
error: Bad exit status from /var/tmp/rpm-tmp.14344 (%build)
Comment 4 Hin-Tak Leung 2008-05-21 09:36:22 EDT
Same problem with wine 1.0 rc1. 
http://prdownloads.sourceforge.net/wine/wine-1.0-rc1.tar.bz2

I just upgraded to f9. f8-compiled wine 1.0 rc1 was linked against 
older version of the ldap libraries, so I had to take it off and rebuild.
'rpmbuild -bb' the same rpm spec (which worked on f8 a week or two ago)
or manually with "./configure && make depend && make" results in the exact 
same error.

This is obviously a showstopper for anybody who is looking at having 
the upcoming wine 1.0 on fedora 9.

Comment 5 Marcus Meissner 2008-05-21 16:50:35 EDT
it is a out of stack space problem. there are gcc bugs already, and it is 
fixed in 4.3 branch

ulimit -s unlimited
Comment 6 Hin-Tak Leung 2008-05-21 19:06:29 EDT
Confirming 'ulimit -s unlimited' worked around the problem. Just finished
building wine 1.0 rc1 on f9. Thanks.

This should close when fedora provides a gcc update.
Comment 7 Jakub Jelinek 2008-05-29 12:54:51 EDT

*** This bug has been marked as a duplicate of 440139 ***

Note You need to log in before you can comment on or make changes to this bug.