Bug 445500 - Fail receiving message from consumer B when consumer A is canceled
Fail receiving message from consumer B when consumer A is canceled
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: qpid-cpp (Show other bugs)
beta
All Linux
urgent Severity medium
: ---
: ---
Assigned To: Kim van der Riet
Kim van der Riet
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-07 04:00 EDT by Arnaud Simon
Modified: 2009-05-07 16:09 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-12 10:00:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Arnaud Simon 2008-05-07 04:00:35 EDT
Description of problem:
The java test
org.apache.qpid.test.unit.topic.DurableSubscriptionTest#testDurabilityAUTOACK is
failing when the async store is used. 
This test creates a durable and a standard subscriber for topic T1. It then
sends a messages to T1 that is consumed by the two subscribers. The durable
subscriber is then closed i.e. its subscription is canceled. A message is
finally published but not received by the remaining standard subscriber. 

Steps to Reproduce:
1) edit ../qpid/java/ccp.async.testprofile and set the properties test and test1
respectively to test=*urableSubscriptionTest and test1=*urableSubscriptionTest
2) in ../qpid/java/ run: ant -Dprofile=cpp.async test 

Additional info:
This bug only affects the async store
Comment 1 Arnaud Simon 2008-05-08 10:03:11 EDT
The incriminated test:
org.apache.qpid.test.unit.topic.DurableSubscriptionTest#testDurabilityAUTOACK
has been excluded from CC. 

Note: make sure this test is removed form the exclude list before closing this bug 
Comment 2 Gordon Sim 2008-05-11 14:35:31 EDT
This is due to the bug described in QPID-1048 and is now fixed.

https://issues.apache.org/jira/browse/QPID-1048
Comment 3 Arnaud Simon 2008-05-12 09:59:46 EDT
this test has been removed form the exclusion list and now passes 

Note You need to log in before you can comment on or make changes to this bug.