Bug 445511 - Printers showing Trashing internal memory
Printers showing Trashing internal memory
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: cups (Show other bugs)
4.2
i386 Linux
low Severity low
: rc
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-07 06:58 EDT by Pablo Iranzo Gómez
Modified: 2008-07-24 01:57 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-24 01:57:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Document they try to print (430.40 KB, application/pdf)
2008-05-07 06:58 EDT, Pablo Iranzo Gómez
no flags Details
ps2ps conversion as described by Tim (431.56 KB, application/postscript)
2008-05-07 07:02 EDT, Pablo Iranzo Gómez
no flags Details
PDF- and PS- filtered file (954.19 KB, application/octet-stream)
2008-05-07 07:45 EDT, Tim Waugh
no flags Details
PPD for the printer (11.64 KB, application/octet-stream)
2008-05-07 09:19 EDT, Pablo Iranzo Gómez
no flags Details
All process (two filters) result (947.02 KB, application/postscript)
2008-05-07 09:27 EDT, Pablo Iranzo Gómez
no flags Details

  None (edit)
Comment 1 Pablo Iranzo Gómez 2008-05-07 06:58:19 EDT
Created attachment 304751 [details]
Document they try to print
Comment 4 Pablo Iranzo Gómez 2008-05-07 07:02:03 EDT
Created attachment 304754 [details]
ps2ps conversion as described by Tim
Comment 5 Pablo Iranzo Gómez 2008-05-07 07:08:42 EDT
Printers can print other files, printers have been replaced, connection cable
has been replaced (using parallel port), and other documents can be printed.

This document can be printed if just sending the images without photographs.

Thanks!
Pablo
Comment 6 Tim Waugh 2008-05-07 07:45:34 EDT
Created attachment 304758 [details]
PDF- and PS- filtered file

Hi Pablo,

The attachment in comment #4 looks like you given pstops the original PDF 
instead of the output from pdftops as I described.

Starting from gps-5-5-2008.pdf, here is how CUPS processes the document for a
PostScript printer:

PPD=/etc/cups/ppd/myprinter.ppd /usr/lib/cups/filter/pdftops \
  1 me '' 1 '' < gps-5-5-2008.pdf > pdftops.ps
PPD=/etc/cups/ppd/myprinter.ppd /usr/lib/cups/filter/pstops \
  1 me '' 1 '' < pdftops.ps > pstops.ps

The resulting pstops.ps file (i.e. the output from pstops.ps) is what is then
handed off to the printer.

I don't have the PPD for the printer in question here (i.e. the
/etc/cups/ppd/queue.ppd file for that queue); you need to attach that.

Trying with a random PostScript printer PPD I happen to have available here,
here is the pstops.ps *I* get when running the above commands on Fedora 8.
Comment 7 Tim Waugh 2008-05-07 07:46:22 EDT
Please attach the PPD file they are actually using.
Comment 8 Pablo Iranzo Gómez 2008-05-07 09:19:01 EDT
Sorry, I exec it as two separate commands, I'm going to do that extra step and
let you know.

Attaching ppd as required.

Will update entry afterwards
Comment 9 Pablo Iranzo Gómez 2008-05-07 09:19:15 EDT
Created attachment 304764 [details]
PPD for the printer
Comment 10 Pablo Iranzo Gómez 2008-05-07 09:27:51 EDT
Created attachment 304767 [details]
All process (two filters) result
Comment 11 Pablo Iranzo Gómez 2008-05-07 09:34:17 EDT
Printer still does no printing even with the two-filter file (attached previously)

Thanks!
Pablo
Comment 12 Tim Waugh 2008-05-07 10:13:28 EDT
Meaning that the printer still displays 'Trashing internal memory'?

Sounds like it needs one of:
(a) a firmware upgrade, or
(b) extra RAM installed, or
(c) Lexmark to provide input
Comment 13 Pablo Iranzo Gómez 2008-05-07 10:24:50 EDT
Tim, as other printers can print this file using the same amount of RAM, we're
going to address this issue with Lexmark and firmware upgrade (just addon card
as I found on their website).


Thank you very much for your attention
Pablo
Comment 14 Pablo Iranzo Gómez 2008-07-24 01:57:06 EDT
Customer is working on this with T-Systems, Fujitsu-Siemens and Lexmark, it only
happens when using parallel port with a few T200 systems, using usb or network
print server works ok, as well as feeding using raw PDF to the printer, it just
fails with ps conversion and printing over parallel...

Thanks Tim :)

Note You need to log in before you can comment on or make changes to this bug.