Bug 445533 - network manager has both wired and wireless adapters up
network manager has both wired and wireless adapters up
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
9
All Linux
low Severity medium
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-07 09:31 EDT by Thomas J. Baker
Modified: 2008-05-28 22:40 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-19 13:01:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Thomas J. Baker 2008-05-07 09:31:44 EDT
I've got a Dell M1210 laptop with intel 3945 wireless and b44 wired connections.
I've noticed recently with nm (currently
NetworkManager-0.7.0-0.9.3.svn3623.fc9.x86_64) that when I plug in the wired
ethernet, the wireless does not get shut down. There is an ifcfg-eth0 file for
the wired adapter (standard dhcp) but none for the wireless. The DHCP server is
set up so that when connecting with either adapter to appropriate networks, the
laptop gets the same ip address.

nm-tool shows both states as connected and routing points to both devices. Some
obfuscation applied:

continuity> nm-tool

NetworkManager Tool

State: connected

- Device: eth0 ----------------------------------------------------------------
  Type:              Wired
  Driver:            b44
  State:             connected
  HW Address:        <removed>

  Capabilities:
    Supported:       yes
    Carrier Detect:  yes
    Speed:           100 Mb/s

  Wired Settings

  IP Settings:
    IP Address:      132.177.241.<ip>
    Subnet Mask:     255.255.255.0
    Broadcast:       132.177.241.255
    Gateway:         132.177.241.<gw>
    DNS:             132.177.241.<one>
    DNS:             132.177.241.<two>
    DNS:             132.177.241.<three>


- Device: wlan0 ----------------------------------------------------------------
  Type:              802.11 Wireless
  Driver:            iwl3945
  State:             connected
  HW Address:        <removed>
  Capabilities:
    Supported:       yes

  Wireless Settings
    WEP Encryption:  yes
    WPA Encryption:  yes
    WPA2 Encryption: yes

  Wireless Access Points(* = Current AP)
    *RCC:            Infra, <removed>, Freq 2437 MHz, Rate 0 Mb/s, Strength 92

  IP Settings:
    IP Address:      132.177.241.<ip>
    Subnet Mask:     255.255.255.0
    Broadcast:       132.177.241.255
    Gateway:         132.177.241.<gw>
    DNS:             132.177.241.<one>
    DNS:             132.177.241.<two>
    DNS:             132.177.241.<three>


continuity> netstat -rn
Kernel IP routing table
Destination     Gateway         Genmask         Flags   MSS Window  irtt Iface
132.177.241.0   0.0.0.0         255.255.255.0   U         0 0          0 eth0
132.177.241.0   0.0.0.0         255.255.255.0   U         0 0          0 wlan0
0.0.0.0         132.177.241.<gw>0.0.0.0         UG        0 0          0 eth0
continuity>

This is from a standard preview install with all rawhide updates applied. The
ifcfg-eth0 was created by anaconda. I tried explicitly making it nm-controlled
but it didn't make a difference. I just started my laptop from suspend with the
wired etherned plugged in. Network was disabled as sometimes happens when
resuming. After I enabled networking, nm first enabled the wired device and then
the wireless one.
Comment 1 John Poelstra 2008-05-07 14:56:22 EDT
I've seen the same thing on an IBM ThinkPad
Comment 2 Dan Williams 2008-05-08 14:30:16 EDT
This is expected; NetworkManager will bring up any device it find that has a
connection with autoconnect=TRUE.  If you do not want to autoconnect a device,
turn off the "Connect automatically" option for the connection by using the
Connection Editor (/usr/bin/nm-connection-editor, or right-click on the applet
and choose "Edit Connections...").  Wired devices without an ifcfg file are also
brought up automatically with DHCP, if you don't want that to happen then create
a system-config-network configuration for the device and chekc "Controlled by
NetworkManager".

Please reopen if you have further questions or this doesn't work.  Thanks!
Comment 3 Thomas J. Baker 2008-05-08 15:04:33 EDT
My wired device has an ifcfg file and is set to be controlled by nm. What am I
missing? It used to be that if/when wired was plugged in, it was used and
wireless was turned off. 
Comment 4 Bug Zapper 2008-05-14 06:46:11 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 5 Dan Williams 2008-05-19 13:01:03 EDT
Thomas: latest updates to NM have enabled the multiple device support
functionality.  This has always been present in F9 and was recently backported
to F8.  You shouldn't notice any real difference in the operation of your
computer, simply that when you disconnect the cable you'll still be connected to
wireless.  If you'd like to turn wireless off, you can uncheck the Enable
Wireless checkbox in the right-click menu of the applet.
Comment 6 Thomas J. Baker 2008-05-19 15:22:15 EDT
I now understand that this is a feature but in my case, it causes problems. Both
up adapters end up with the same IP address (my DHCP is configured that way on
purpose). I'm not positive but I also believe this causes the wireless adapter
to be used for the local subnet since it's listed first in the routing table
(see comment #1). In most cases, I'm trying to get the added benefit of speed
when I plug in the wired adapter and at work and home, the main systems I talk
with are on the same subnet. Since wlan0 is up, my packets take the slow route.

Shutting off wireless works for me but it might be nice to have a simple option
of "Use one network device at a time" or something like that. I can see reasons
for allowing more than one but there's also my reason of only wanting one. Thanks.
Comment 7 Jan "Yenya" Kasprzak 2008-05-27 04:49:08 EDT
I want to add a "me too" to the comment #6. Surely it is possible to have
wireless disabled by default and enable it only manually, but it is not nice
from the usability point of view. There should be an option for "when the wired
ethernet is plugged in, shut down all wireless interfaces, and when it is
unplugged, try to enable the wireless ones" (as it worked in F8).

As I guess that most desktop users want this beaviour rather than "keep all
autoconfigured interfaces up", I would even say the former should be the default.
Comment 8 adhisimon 2008-05-28 22:40:28 EDT
I just wanna tell that I'm on the comment #6 and comment #7 side. 

Note You need to log in before you can comment on or make changes to this bug.