Bug 445535 - netstat displays incorrect sctp statistics
netstat displays incorrect sctp statistics
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: net-tools (Show other bugs)
5.1
All Linux
low Severity low
: rc
: ---
Assigned To: Jiri Popelka
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-07 09:49 EDT by Steven Friedman
Modified: 2011-07-13 08:42 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-07-13 08:42:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch which fixes displaying sctp statistics (11.74 KB, application/octet-stream)
2008-06-19 02:51 EDT, Zdenek Prikryl
no flags Details

  None (edit)
Description Steven Friedman 2008-05-07 09:49:32 EDT
Description of problem:
The results of 'netstat -an' show incorrect results for sctp connections.  I am
presuming that this is a bug in how lksctp sets the variables and not netstat in
reading the variables.


Version-Release number of selected component (if applicable):
lksctp-tools-1.0.6-1.el5.1
net-tools-1.60-73


How reproducible:
Every time.


Steps to Reproduce:
1. Open a one-to-one client sctp socket.
2. Type 'netstat -an'
3. Output shows faulty Recv-Q, Send-Q and IP addresses.
  
Actual results:
sctp   63488      1 0.0.128.0:17503         255.255.255.255:9877    ESTABLISHED


Expected results:
Correct values for all of the columns.


Additional info:
Comment 1 Zdenek Prikryl 2008-05-14 09:04:24 EDT
Hello,
it doesn't seem that it is a bug in lksctp, because lksctp uses standard bind(2)
function. Further, if you enable a debug mode, then every address is printed
correctly. So, it seems that the bug is either in netstat (net-tools) or in kernel.

Adding the maintainer of net-tools, so he can add his opinion.
Comment 2 Zdenek Prikryl 2008-06-18 04:09:56 EDT
This is not a bug in lksctp-tools, but in netstat.
Reassigning to right component.
Comment 3 Zdenek Prikryl 2008-06-19 02:51:17 EDT
Created attachment 309819 [details]
Patch which fixes displaying sctp statistics

This patch should fix displaying sctp statistics. Please try it and let me know
if it works.
Comment 4 Steven Friedman 2008-06-26 15:55:42 EDT
Works for me.
Comment 5 Radek Vokal 2008-07-08 02:38:24 EDT
Thanks for the patch, applied on net-tool-1.60-88 in rawhide.
Comment 9 RHEL Product and Program Management 2010-08-09 14:15:22 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 11 RHEL Product and Program Management 2011-01-11 15:08:12 EST
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 12 RHEL Product and Program Management 2011-01-11 18:08:53 EST
This request was erroneously denied for the current release of
Red Hat Enterprise Linux.  The error has been fixed and this
request has been re-proposed for the current release.
Comment 14 RHEL Product and Program Management 2011-05-31 09:27:23 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 15 Jiri Popelka 2011-07-13 08:42:27 EDT
Closing per comment #13.

Note You need to log in before you can comment on or make changes to this bug.