Bug 445547 - sshd install doesn't setup keys
sshd install doesn't setup keys
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: openssh (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Tomas Mraz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-07 11:00 EDT by David Wilson
Modified: 2008-05-12 09:00 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-07 13:03:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Wilson 2008-05-07 11:00:13 EDT
Description of problem:

On FC9 Preview when a 'yum install sshd' is done there are no keys installed.
I did the following:

ssh-keygen -t rsa -f /etc/ssh/ssh_host_rsa_key
ssh-keygen -t dsa -f /etc/ssh/ssh_host_dsa_key
ssh-keygen -t rsa1 -f /etc/ssh/ssh_host_key
 


Version-Release number of selected component (if applicable):
FC9 - Preview

How reproducible:
Very

Steps to Reproduce:
1.  install sshd
2.  Look in /etc/ssh/ to see if any keys are there
3.  None found
  
Actual results:

sshd will refuse to start without the keys
Expected results:
I would expect the install script to install sshd and enable it in the startup
scripts and start the program after it is installed. 

Additional info:
Comment 1 Bill Nottingham 2008-05-07 13:03:27 EDT
This is done by the sshd startup script, not the package installation.
Comment 2 David Wilson 2008-05-07 16:02:26 EDT
It certainly didn't install the keys when I started it.  I tried running it and
it complained about keys not being there.
Comment 3 Tomas Mraz 2008-05-12 09:00:30 EDT
How did you try to run sshd?

I cannot reproduce your problem here. If there are no keys in /etc/ssh/ then
'service sshd start' finely generates the keys for me.

Note You need to log in before you can comment on or make changes to this bug.