Bug 445551 - Slow and multiple access to NFS shares caused by LD_LIBRARY_PATH
Slow and multiple access to NFS shares caused by LD_LIBRARY_PATH
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: nfs-utils (Show other bugs)
5.1
All Linux
low Severity medium
: rc
: ---
Assigned To: Steve Dickson
:
: 440444 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-07 11:20 EDT by Patrick Gendron
Modified: 2008-05-08 09:09 EDT (History)
1 user (show)

See Also:
Fixed In Version: kernel-2.6.18-84.el5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-08 09:07:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Patrick Gendron 2008-05-07 11:20:51 EDT
Description of problem:
The NFS client doesn't seem to cache information and generates large amount of
traffic.  A single "ls" command on a NFS mountpoint (NFS3, default options,
server is RHEL5) generates about 60 entries in wireshark (V3 Access call and
reply) and will do so even for consecutive calls of the same command.   For
comparison, accessing the same NFS location from a RHEL4 client generates about
5 entries in wireshark and successive calls do not generate traffic.

This seems somehow related to the LD_LIBRARY_PATH environment variable that
contains NFS mounted paths.  When the variable is emptied or contains local
paths, everything is ok.  In fact, runnning any command when the LD_LIBRARY_PATH
contains NFS mountpoints generates between 50 and 100 wireshark entries, per
mountpoint!

This slows down all commands in an NFS based environment, especially tools like
configure.

Version-Release number of selected component (if applicable):
NFS server and client: RHEL 5.1 x86_64 or i386
kernel 2.6.18-53.1.14.el5 #1 SMP
nfs-utils-1.0.9-24.el5
GNU ld version 2.17.50.0.6-5.el5

How reproducible:
Always

Steps to Reproduce:
1. Mount a NFS share /mnt/nfsserver
2. export LD_LIBRARY_PATH=/mnt/nfsserver
3. any command will be slowed down!
  
Actual results:


Expected results:


Additional info:
Comment 1 Patrick Gendron 2008-05-07 22:19:49 EDT
It seems that the problem has been corrected in upcoming release of RHEL5.  I
installed the packages:

kernel-2.6.18-84.el5
nfs-utils-1.0.9-32.el5

and the problem is now fixed.

Comment 2 Steve Dickson 2008-05-08 09:07:40 EDT
Cool... if the problem comes back please go ahead and reopen this bz...
Comment 3 Steve Dickson 2008-05-08 09:09:27 EDT
*** Bug 440444 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.