This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 445555 - Busy-loop when CUPS backend fails
Busy-loop when CUPS backend fails
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: foomatic (Show other bugs)
8
All Linux
high Severity high
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F8Target
  Show dependency treegraph
 
Reported: 2008-05-07 11:36 EDT by Tim Waugh
Modified: 2008-09-28 14:43 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-28 14:41:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Tim Waugh 2008-05-07 11:36:18 EDT
Description of problem:
The foomatic-rip filter can go into a busy loop when the CUPS backend fails. 
Observed with an smb://... URI for a password-protected share, with the
gutenprint-ijs-simplified foomatic driver for an Epson Stylus D68.

Version-Release number of selected component (if applicable):
foomatic-3.0.2-59.fc8

How reproducible:
100%

Steps to Reproduce:
1.Set up an smb:// queue with no auth info in the URI, pointing at a share that
is set to refuse guest logins.
2.Use the recommended Epson Stylus D68 PPD, i.e. gutenprint-ijs-simplified
(foomatic).
3.Print a job.
4.Run 'top' and observe CPU usage.
  
Actual results:
foomatic-rip is busy-looping

Additional info:
It's because the foomatic renderer process is not correctly collecting the child
process's status and propagating it.
Comment 1 Tim Waugh 2008-05-07 11:46:48 EDT
Fix checked into devel.  Requires further testing with newer upstream
foomatic-filters.
Comment 2 Tim Waugh 2008-05-08 04:30:56 EDT
Fixed in CVS for F-8 and F-9.  F-7 is not affected.
Comment 3 Fedora Update System 2008-09-05 09:06:06 EDT
foomatic-3.0.2-65.fc8 has been submitted as an update for Fedora 8.
http://admin.fedoraproject.org/updates/foomatic-3.0.2-65.fc8
Comment 4 Fedora Update System 2008-09-05 09:08:00 EDT
foomatic-3.0.2-65.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/foomatic-3.0.2-65.fc9
Comment 5 Fedora Update System 2008-09-11 13:04:10 EDT
foomatic-3.0.2-66.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update foomatic'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-7884
Comment 6 Fedora Update System 2008-09-11 13:09:25 EDT
foomatic-3.0.2-66.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update foomatic'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F8/FEDORA-2008-7924
Comment 7 Fedora Update System 2008-09-24 20:00:09 EDT
foomatic-3.0.2-67.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update foomatic'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-7884
Comment 8 Fedora Update System 2008-09-24 20:21:56 EDT
foomatic-3.0.2-67.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update foomatic'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F8/FEDORA-2008-7924
Comment 9 Fedora Update System 2008-09-28 14:41:21 EDT
foomatic-3.0.2-67.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 10 Fedora Update System 2008-09-28 14:43:31 EDT
foomatic-3.0.2-67.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.