This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 445579 - (Ivan) Sound card plays audio files but no sound is heard
Sound card plays audio files but no sound is heard
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: alsa-utils (Show other bugs)
9
All Linux
low Severity medium
: ---
: ---
Assigned To: Jaroslav Kysela
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-07 14:23 EDT by Ivan
Modified: 2009-07-14 11:29 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-14 11:29:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
pulseaudio.log (14.00 KB, text/plain)
2008-05-07 14:27 EDT, Ivan
no flags Details
log from pulseaudio -vvv (6.25 KB, application/octet-stream)
2008-05-07 14:27 EDT, Ivan
no flags Details

  None (edit)
Description Ivan 2008-05-07 14:23:04 EDT
Description of problem:
My soundcard seams to work but no sound is heard during playback.

I have this soundcard:
$ /sbin/lspci |grep audio
00:02.7 Multimedia audio controller: Silicon Integrated Systems [SiS] AC'97
Sound Controller (rev a0)

When I do this:
aplay -D hw:0 /usr/share/sounds/startup3.wav

it doesn't show any errors and seams to play but no sound is heard.

I tried also running alsamixer -c 0 and all outputs are around 70-80% of volume.

I also tried playing one video ogg theora from redhatmagazine.com and it plays
but I still don't hear any audio from speakers. 

I also tried playing with:
pasuspender /usr/bin/aplay -- -D hw:0 /usr/share/sounds/startup3.wav

also I tried killing pulseaudio and starting it again with:
pulseaudio -vvv

and I'll attach the log.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Ivan 2008-05-07 14:27:08 EDT
Created attachment 304793 [details]
pulseaudio.log

this log it created by
grep pulseaudio /var/log/messages
Comment 2 Ivan 2008-05-07 14:27:59 EDT
Created attachment 304794 [details]
log from pulseaudio -vvv

log from pulseaudio -vvv
Comment 3 Bug Zapper 2008-05-14 06:47:31 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 petrosyan 2008-05-17 23:58:32 EDT
start 'gnome-volume-control' go to the 'Switches' tab and enable the 'Speaker'
checkmark. Let me know if it fixes your problem.
Comment 5 Leo Canale 2008-05-19 10:54:20 EDT
(In reply to comment #4)
> start 'gnome-volume-control' go to the 'Switches' tab and enable the 'Speaker'
> checkmark. Let me know if it fixes your problem.

[root@scooter ~]# lspci
00:00.0 Host bridge: Intel Corporation 82845 845 [Brookdale] Chipset Host Bridge
(rev 04)
00:01.0 PCI bridge: Intel Corporation 82845 845 [Brookdale] Chipset AGP Bridge
(rev 04)
00:1d.0 USB Controller: Intel Corporation 82801CA/CAM USB Controller #1 (rev 02)
00:1d.2 USB Controller: Intel Corporation 82801CA/CAM USB Controller #3 (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev 42)
00:1f.0 ISA bridge: Intel Corporation 82801CAM ISA Bridge (LPC) (rev 02)
00:1f.1 IDE interface: Intel Corporation 82801CAM IDE U100 Controller (rev 02)
00:1f.5 Multimedia audio controller: Intel Corporation 82801CA/CAM AC'97 Audio
Controller (rev 02)
00:1f.6 Modem: Intel Corporation 82801CA/CAM AC'97 Modem Controller (rev 02)
01:00.0 VGA compatible controller: nVidia Corporation NV17 [GeForce4 440 Go]
(rev a3)
02:00.0 Ethernet controller: 3Com Corporation 3c905C-TX/TX-M [Tornado] (rev 78)
02:01.0 CardBus bridge: Texas Instruments PCI4451 PC card Cardbus Controller
02:01.1 CardBus bridge: Texas Instruments PCI4451 PC card Cardbus Controller
02:01.2 FireWire (IEEE 1394): Texas Instruments PCI4451 IEEE-1394 Controller
[root@scooter ~]# 

I have the same issue on my inspiron 8200 laptop. After boot into gnome I start
'gnome-volume-control' then I need mute and then un-mute PCM slider then sound
will work. Also shows no errors. Let me know what other info I can provide to
help troubleshoot this.
Comment 6 petrosyan 2008-05-19 11:02:07 EDT
do you have alsa-utils package installed?
Comment 7 Lennart Poettering 2008-05-21 10:21:50 EDT
This looks like yet another of those incomplete default mixer initialization
problems. Reassigning to alsa-utils.
Comment 8 Ivan 2008-05-22 12:06:34 EDT
hey there!

It took me a while to see that there are more than one comment here!

anyway, i opened 'gnome-volume-control', and no matter what device and engine
(pulseaudio, alsa, oss etc.) i select, when look in into switches, i can't find
the 'Speaker', so i can't select/unselect it... it's simply not there!

maybe it would help if i said that before this fedora on my laptop, i tried
ubuntu  7.10 and 8.04, as well as fedora 8, and basically had same problem with
any of them...
Comment 9 Leo Canale 2008-05-25 08:14:37 EDT
(In reply to comment #6)
> do you have alsa-utils package installed?
Yes!
[root@scooter ~]# rpm -qa alsa-utils
alsa-utils-1.0.16-2.fc9.i386
[root@scooter ~]#
I also noticed that I hear a click sound at the nash kernel boot time. Like it
clicks on and clicks off again a couple of seconds later.
Comment 10 Ivan 2008-05-26 10:01:52 EDT
yeah, the same clicking sound from speakers is happening to me too! any ideas?
Comment 11 Vedran Miletić 2008-12-26 18:28:26 EST
This is a long time problem, and it is also a duplicate of bug 196597.
Comment 12 Bug Zapper 2009-06-09 20:40:06 EDT
This message is a reminder that Fedora 9 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 9.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '9'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 9's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 9 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 13 Bug Zapper 2009-07-14 11:29:38 EDT
Fedora 9 changed to end-of-life (EOL) status on 2009-07-10. Fedora 9 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.