Bug 445595 - Wings 3D won't start
Wings 3D won't start
Status: CLOSED DUPLICATE of bug 451570
Product: Fedora
Classification: Fedora
Component: wings (Show other bugs)
9
i386 Linux
low Severity high
: ---
: ---
Assigned To: Gérard Milmeister
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-07 16:54 EDT by Frank Murphy
Modified: 2008-07-06 07:29 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-06 07:29:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
glxinfo output (13.05 KB, text/plain)
2008-06-08 06:16 EDT, Frank Murphy
no flags Details

  None (edit)
Description Frank Murphy 2008-05-07 16:54:14 EDT
Description of problem: Wings 3D won't stay open


Version-Release number of selected component (if applicable):
wings-0.99.02-1.fc9.i386

How reproducible:


Steps to Reproduce:
1. Applications 
2. Graphics
3. Wings 3D
  
Actual results:
Briefest of window flash

Expected results:
Working wings3d

Additional info from terminal: 
#wings 
erlexec: Error 2 executing '/usr/lib/wings/bin/beam.smp'.
Comment 1 Bug Zapper 2008-05-14 06:47:56 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 Gérard Milmeister 2008-06-06 14:45:34 EDT
What graphics card is it?
Comment 3 Frank Murphy 2008-06-06 14:59:07 EDT
01:00.0 VGA compatible controller: nVidia Corporation G72 [GeForce 7300 LE] (rev a1)

Using nv drivers 

Comment 4 Gérard Milmeister 2008-06-06 15:41:17 EDT
nv does not support accelerated opengl. Probably wings doesn't work with
software opengl.
Comment 5 Frank Murphy 2008-06-06 15:47:30 EDT
What card would you reccomend, maker\model?
Comment 6 Gérard Milmeister 2008-06-06 16:07:19 EDT
Best to keep your card, and install the proprietary drivers.
Comment 7 Frank Murphy 2008-06-08 05:18:56 EDT
Installed the proprietry drivers from freshrpms, didn't work so tried the "f9"
drivers. Still no joy

nvidia-x11-drv-169.12-1.fc8.i386
nvidia-x11-drv-173.08-1.fc9

Thought I have got wings working on another box using the 9 driver.
with a 512mb nvidia card.
Comment 8 Gérard Milmeister 2008-06-08 06:05:06 EDT
Please provide the output of glxinfo (package glx-utils)
Comment 9 Frank Murphy 2008-06-08 06:16:18 EDT
Created attachment 308646 [details]
glxinfo output
Comment 10 Hezekiah M. Carty 2008-06-08 14:57:28 EDT
I have the same problem on Fedora 9 AMD64/x64-64, on a Core 2 Duo system.  My
video card is an Intel X3100.  I do have working 3D acceleration, though it is a
little slow.

I had the same problem and was able to fix/work around the problem by creating
beam.smp as a symbolic link to beam (as root):

cd /usr/lib64/wings/bin
ln -s beam beam.smp

Wings3D now works for me from the command line (run "wings") or from the Gnome
menu entry.
Comment 11 Frank Murphy 2008-06-08 15:15:19 EDT
That work here to just removed the "64"
ln -s beam beam.smp

works gui and cli

Comment 12 Frank Murphy 2008-06-08 15:36:08 EDT
Have also got it working in rawhide, but had to fiddle with selinux.
Comment 13 Sébastien Scour 2008-07-06 06:16:56 EDT
I had the exact same problem on my system.
Hezkiah's solution worked fine for me (hooray !) Wings 3D now runs fine.
My laptop system is a fedora 9 X64 with Core 2 Duo (T7100) and a Nvidia Geforce
8400M G videocard (128MB)

Now works gui an cli.

Thanks.
Comment 14 Gérard Milmeister 2008-07-06 07:29:45 EDT

*** This bug has been marked as a duplicate of 451570 ***

Note You need to log in before you can comment on or make changes to this bug.