Bug 445597 - Dovecot cannot load ssl certificate on x86_64 systems
Dovecot cannot load ssl certificate on x86_64 systems
Status: CLOSED DUPLICATE of bug 253363
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: dovecot (Show other bugs)
5.1
x86_64 Linux
high Severity high
: rc
: ---
Assigned To: Dan Horák
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-07 17:08 EDT by Brad Smith
Modified: 2008-05-08 02:17 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-08 02:17:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brad Smith 2008-05-07 17:08:33 EDT
Description of problem:
I've encountered the bug described here:

http://www.cyberciti.biz/tips/rhel-dovecot-error-while-loading-shared-libraries.html

a couple of times now. Basically, on a 64-bit system, dovecot hangs when trying
to load an ssl cert unless the following is added to dovecot.conf:

  login_process_size = 64

Version-Release number of selected component (if applicable):
dovecot-1.0-1.2.rc15.el5

How reproducible:
Always, from what I've seen

Steps to Reproduce:
0. Use a 64-bit system
1. Install dovecot
2. Edit dovecot.conf and set protocols to, eg, imaps
3. Start dovecot
4. Connect, eg  mutt -f imaps://user@localhost
5. Hang forever (or at least a really long time)

Adding the line mentioned above to dovecot's config and restarting the daemon
solves the problem.
Comment 1 Dan Horák 2008-05-08 02:17:03 EDT

*** This bug has been marked as a duplicate of 253363 ***

Note You need to log in before you can comment on or make changes to this bug.