Bug 4456 - unabel to access alias IP dialog
unabel to access alias IP dialog
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: linuxconf (Show other bugs)
6.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael K. Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-08-09 23:28 EDT by Aaron VanDevender
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-09-20 12:13:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Aaron VanDevender 1999-08-09 23:28:31 EDT
dialog Config->Networking->Server Tasks->IP aliases for
virtual hosts gives the names of adapters.

when eth0 is selected, linuxconf crashes.

Error message from remadmin :IMLIB ERROR: SHM can't get SHM
Identifier for Shared Pixmap Wrapper
Error message from remadmin :             Falling back on
Shared XImages
Error message from remadmin :IMLIB ERROR: SHM can't get SHM
Identifier for Shared XImage
Error message from remadmin :             Falling back on
XImages
Error message from remadmin :
Error message from remadmin :Gdk-ERROR **: BadAlloc
(insufficient resources for operation)
Error message from remadmin :  serial 22091 error_code 11
request_code 53 minor_code 0
Error message from remadmin :
Error message from remadmin :aborting...
remadmin (GUI frontend) exiting abnormaly

One aliased IP was configured for eth0 (in adition to the
regular IP).

Aliased IP was removed the old fashioned way (ifconfig
eth0:0 down). The linuxconf dialog still crashes even
without any aliased IPs.

linuxconf also crashes with same error when lo0 is selected
instead of eth0.
Comment 1 Michael K. Johnson 1999-09-20 12:13:59 EDT
This sounds like some program on your system is leaking shared
memory regions.  I can't reproduce this here.

You can use ipcs to list shared memory segments, and ipcrm to
delete unused segments.

One other thing to try is upgrading to the latest linuxconf in
updates, if you haven't already.  There could be some bug that
I don't know about in the earlier version.

If there are no leaked shared memory segments sitting around on
your system and the new linuxconf does not fix this either, then
please reopen this bug, and include the output of ipcs and of
rpm -q linuxconf gnome-linuxconf gtk+

Note You need to log in before you can comment on or make changes to this bug.