Bug 445621 - index*.html files no longer needed?
index*.html files no longer needed?
Status: CLOSED RAWHIDE
Product: Fedora Documentation
Classification: Fedora
Component: homepage (Show other bugs)
devel
All Linux
low Severity low
: ---
: ---
Assigned To: Paul W. Frields
Karsten Wade
:
Depends On:
Blocks: 500474
  Show dependency treegraph
 
Reported: 2008-05-07 21:55 EDT by Jens Petersen
Modified: 2013-01-09 23:41 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-04 20:30:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jens Petersen 2008-05-07 21:55:44 EDT
Description of problem:
The /usr/share/doc/HTML/index*.html files are basically being obsoleted
by http://start.fedoraproject.org/ and so can be removed for F10 I think.
The functionality offered is basically the same and the website is going
to be translated I believe.
Comment 1 Bug Zapper 2008-05-14 06:48:48 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 Tony Fu 2008-09-09 23:10:57 EDT
requested by Jens Petersen (#27995)
Comment 3 Paul W. Frields 2008-11-13 08:44:21 EST
Moving components so this doesn't get missed in F11 time frame.  Since it's not hurting anything, it's not a disaster, but this content *is* obsolete and really needs to be removed.
Comment 4 Karsten Wade 2008-11-13 16:12:28 EST
Sorry, I forget, what appears in Firefox/Seamonkey when starting up offline?  What is supposed to happen?

Because of my findings (below), I wonder if this content truly is obsolete.

Currently, in Fedora 9:

* Seamonkey defaults to /usr/share/doc/HTML/index.html
* Firefox loads "start.fp.o" from cache, in my instance the CSS is missing
** The CSS is pulled via HTTP
** If switched to work offline, it throws an "Address not found" error
*** This is actually an ugly experience, v. throwing up the index*.html files
** When switched back to work online, it shows the start.fp.o (without CSS)
** What does it do when the cache is empty?  Haven't been able to test that.
*** E.g., Ctrl+Shift+r(eload) continues to pull up the CSS-less start page

So, for every instance where there is not an Internet connection, the experience is ugly for the user.  I understand that the original intention of start.fp.o was that it would take care of the 80% situation, most people would be connected, etc.  But this is an ugly 20% to leave behind.
Comment 5 Paul W. Frields 2008-11-13 19:32:07 EST
This is probably not an issue that Docs should be deciding, but as I recall, when we knew that Firefox was going to change behavior some time back, the winning argument was that we shouldn't work extra hard to make people who are offline think they're not.

I guess you could make a case for a fallback start page that says "You're offline," but someone would have to do some targeted testing to make sure that page didn't persist to the point it was misinforming the user.

I'd like to know what the cacheless situation is, but I'm not in a position to test tonight...
Comment 6 Jason Taylor 2009-01-08 10:21:46 EST
Just checking to see where we are. Are these files something that we are in fact obsoleting or are they going to be around for a while?
Comment 7 Karsten Wade 2009-05-13 01:01:22 EDT
Can we come up with a middle ground idea?

Maybe the startpage.xml that is the /usr/share/doc/HTML/index.html currently could:

* Remove the version specific information (my F10 file says Fedora 9)
* A link to the local release notes
* Mentions that the search bar may not work if the computer is in fact off line

Otherwise, don't bother to add a bunch of overly busy resource links, as we did in the past.  Just those three conceptual changes.
Comment 8 John J. McDonough 2009-07-17 14:10:04 EDT
Change to homepage component.
Comment 9 John J. McDonough 2009-09-21 17:42:54 EDT
As part of F12 planning I checked all the browsers I could find ... I think there were a dozen or more.  The only one that seems to use homepage anymore is lynx. If I recall, it uses it as a default whether or not you are online. I sent a couple of emails to the lynx owner but got no response.  I think (it was a while back) I also posted something to devel-list. Our plan for F12 is to FINALLY leave it out (although it has been converted to Publican!)
Comment 10 John J. McDonough 2009-11-04 20:30:13 EST
Indexhtml is gone from F12

Note You need to log in before you can comment on or make changes to this bug.