Bug 445656 - nscd frequent segfaults
nscd frequent segfaults
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: glibc (Show other bugs)
9
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-08 06:53 EDT by Neal Becker
Modified: 2008-07-23 03:08 EDT (History)
4 users (show)

See Also:
Fixed In Version: 2.8-8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-23 03:08:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Neal Becker 2008-05-08 06:53:44 EDT
Description of problem:
I see these several times/day:
May  8 06:19:23 nbecker1 kernel: nscd[3200]: segfault at 7f90cba628f2 ip
7f9090402e51 sp 416a9d00 error 4 in nscd[7f90903f2000+1e000]


Version-Release number of selected component (if applicable):
rpm -q nscd
nscd-2.8-3.x86_64

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Bug Zapper 2008-05-14 06:50:06 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 Matteo Corti 2008-05-15 09:35:42 EDT
I have the same problem. The first occurence was just after upgrading from F8 to F9.

$ grep nscd messages
May 14 16:28:26 matteo nscd: 1810 invalid persistent database file
"/var/db/nscd/hosts": verification failed
May 14 16:43:53 matteo kernel: nscd[1819]: segfault at ffff42d0 ip 00141b44 sp
afb2bdec error 4 in libpthread-2.8.so[139000+15000]
May 14 16:47:52 matteo nscd: 1823 invalid persistent database file
"/var/db/nscd/hosts": verification failed
May 14 17:03:53 matteo kernel: nscd[1815]: segfault at ffffffd0 ip 00141b44 sp
afbe9e44 error 4 in libpthread-2.8.so[139000+15000]
May 15 08:09:38 matteo nscd: 11843 invalid persistent database file
"/var/db/nscd/hosts": verification failed
May 15 08:56:38 matteo kernel: nscd[11845]: segfault at ffe55ee4 ip b8059025 sp
ade55e40 error 6 in nscd[b8048000+1e000]
May 15 15:04:06 matteo kernel: nscd[3491]: segfault at ffc00014 ip b80e1a40 sp
afda7e54 error 4 in nscd[b80d0000+1e000]
May 15 15:23:24 matteo nscd: 29053 invalid persistent database file
"/var/db/nscd/group": verification failed
May 15 15:23:24 matteo nscd: 29053 invalid persistent database file
"/var/db/nscd/hosts": verification failed

Deleting the cache in /var/db does not solve the problem
Comment 3 Matthew A. R. Sherian 2008-05-16 14:17:06 EDT
Ditto here.
It is mitigated by disabling LDAP authentication.

++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

May 12 12 segfault at 7f032593c3bf ip 7f0235aa3f28 sp 42225d00 error 4 in
nscd[7f0235a93000+1e000]
May 13 10 segfault at 7f70be3ce3bf ip 7f6fcc56af28 sp 40e91d00 error 4 in
nscd[7f6fcc55a000+1e000]
May 13 12 segfault at 41261000 ip 7f281c733eee sp 4125fb50 error 6 in
nscd[7f281c722000+1e000]
May 13 14 segfault at 7f752be45438 ip 7f752a037e16 sp 420ffab0 error 4 in
nscd[7f752a026000+1e000]
May 13 16 segfault at bb0 ip 7fdd43c7ce29 sp 41bb6b10 error 4 in
nscd[7fdd43c6b000+1e000]
May 13 16 segfault at 7fb2aa376744 ip 7fb27223ecd2 sp 4061eb90 error 6 in
nscd[7fb27222d000+1e000]
May 14 10 SELinux is preventing gnotravex (games_t) "write" to socket
(nscd_var_run_t). For complete SELinux messages. run sealert -l
6123dd5e-4c37-4879-8637-bec7d04687ed
May 14 11 segfault at 7f526f7649e7 ip 7f520531f7f4 sp 4175d890 error 4 in
nscd[7f520530e000+1e000]
May 14 13 segfault at 7f9553b3592f ip 7f951a859e90 sp 40721f08 error 4 in
libc-2.8.so[7f951a7d9000+162000]
May 14 14 segfault at 400000013 ip 7fafcb81160b sp 41d6ebc0 error 4 in
nscd[7fafcb7ff000+1e000]
May 14 14 segfault at 7fccaa2e5721 ip 7fcc53dfaf28 sp 41604d00 error 4 in
nscd[7fcc53dea000+1e000]
May 16 10 segfault at 7f988e070079 ip 7f9876d387f4 sp 423d7890 error 4 in
nscd[7f9876d27000+1e000]
May 16 11 segfault at 7f50f397d438 ip 7f50a376fe16 sp 41d15a90 error 4 in
nscd[7f50a375e000+1e000]
Comment 4 Matteo Corti 2008-05-17 01:53:02 EDT
Not really. In my case it happens frequently on three different machines none of
which has LDAP authentication enables. All three just have local accounts.
Comment 5 Kostas Georgiou 2008-05-22 09:16:45 EDT

*** This bug has been marked as a duplicate of 430324 ***
Comment 6 Chris Snook 2008-06-25 13:35:55 EDT
Getting this on a fully-updated F9 x86_64 box using local authentication.  It
*seems* to only happen when logged into my VPN (using NetworkManager + vpnc), so
I think it's not liking something about the switch in resolv.conf.
Comment 7 Fedora Update System 2008-07-08 16:27:28 EDT
glibc-2.8-7 has been submitted as an update for Fedora 9
Comment 8 Fedora Update System 2008-07-23 03:08:25 EDT
glibc-2.8-8 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.