Bug 445662 - tomcat-5.sh - names with spaces are mishandled.
tomcat-5.sh - names with spaces are mishandled.
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: rgmanager (Show other bugs)
5.3
All Linux
medium Severity medium
: rc
: ---
Assigned To: Marek Grac
:
Depends On:
Blocks: 450150
  Show dependency treegraph
 
Reported: 2008-05-08 07:55 EDT by Adam Stokes
Modified: 2010-10-22 20:48 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-20 15:56:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Adam Stokes 2008-05-08 07:55:04 EDT
Description of problem:
 Customer is using RHEL5 Cluster suite, and has configured tomcat-5 resources.
On that resource, the customer has specified a name which contains a white space
(according to Lon from engineering names with spaces are allowed, and if there
are problems they are bugs). The tomcat-5 resource is defined as follows:

<tomcat-5 catalina_base="/usr/share/tomcat5"
config_file="/etc/tomcat5/tomcat5.conf" name="Tomcat Provisionning"
shutdown_wait="30" tomcat_user="tomcat"/>

Therefore the stanza with a space is:

name="Tomcat Provisionning"

Version-Release number of selected component (if applicable):
2.0.31.x

How reproducible:
100%

Steps to Reproduce:
Use something like this 
<tomcat-5 catalina_base="/usr/share/tomcat5"
config_file="/etc/tomcat5/tomcat5.conf" name="Tomcat Provisionning"
shutdown_wait="30" tomcat_user="tomcat"/>

  
Actual results:
 Because of the stanza above, the service simply fails and when checking the
status because of missing quoting on the script /usr/share/cluster/tomcat-5.sh.

Expected results:
Service does not fail

Additional info:
one line fix
--- tomcat-5.sh.orig    2008-05-07 22:32:36.000000000 +0100
+++ tomcat-5.sh 2008-05-07 22:32:49.000000000 +0100
@@ -212,7 +212,7 @@
               return $OCF_ERR_GENERIC
       fi

-       echo $! > $TOMCAT_pid_file
+       echo $! > "$TOMCAT_pid_file"

       clog_service_start $CLOG_SUCCEED
Comment 1 RHEL Product and Program Management 2008-06-04 18:44:09 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 2 Marek Grac 2008-06-05 12:01:41 EDT
Thanks, fixed also in other agents
Comment 3 Fedora Update System 2008-06-11 03:56:04 EDT
rgmanager-2.03.04-1.fc9,gfs2-utils-2.03.04-1.fc9,cman-2.03.04-1.fc9 has been submitted as an update for Fedora 9
Comment 4 Fedora Update System 2008-06-11 19:34:46 EDT
rgmanager-2.03.04-1.fc9, gfs2-utils-2.03.04-1.fc9, cman-2.03.04-1.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update rgmanager gfs2-utils cman'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-5243
Comment 5 Fedora Update System 2008-06-12 22:25:30 EDT
rgmanager-2.03.04-1.fc9, gfs2-utils-2.03.04-1.fc9, cman-2.03.04-1.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 errata-xmlrpc 2009-01-20 15:56:49 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0101.html

Note You need to log in before you can comment on or make changes to this bug.