Bug 445671 - Not able to register clients to satellite 423 on Rhel3 U9
Not able to register clients to satellite 423 on Rhel3 U9
Status: CLOSED DUPLICATE of bug 446087
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Registration (Show other bugs)
423
All Linux
low Severity low
: ---
: ---
Assigned To: Justin Sherrill
Brandon Perkins
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-08 09:38 EDT by Preethi Thomas
Modified: 2008-06-02 17:25 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-19 11:07:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
RHN traceback on registration (198.37 KB, message/rfc822)
2008-05-08 09:38 EDT, Preethi Thomas
no flags Details

  None (edit)
Description Preethi Thomas 2008-05-08 09:38:33 EDT
Description of problem:
Not able to register clients to satellite 423 on Rhel3 U9. results in ISE

Version-Release number of selected component (if applicable):

 rhn-satellite-4.2.2-5-redhat-linux-as-i386-3-embedded-oracle.iso updated to
satellite 423
How reproducible:


Steps to Reproduce:
1. Install & sync rhel3 channels on satellite 423 on rhel 3 u9
2. Try to register a rhel3u9 client to the satellite (rhnreg_ks)

  
Actual results:
ISE occurred message.

Expected results:
Successful registration
Additional info:
attached the trace back
Comment 1 Preethi Thomas 2008-05-08 09:38:33 EDT
Created attachment 304861 [details]
RHN traceback on registration
Comment 2 Preethi Thomas 2008-05-13 08:36:01 EDT
This is happening in the Rhel4 satellite 423 as well.


Comment 3 Clifford Perry 2008-05-16 15:23:56 EDT
Exception Handler Information
Traceback (most recent call last):
  File "/usr/share/rhn/server/apacheRequest.py", line 108, in call_function
    response = apply(func, params)
  File "/usr/share/rhn/server/handlers/xmlrpc/registration.py", line 381, in
add_packages
    server.save_packages()
  File "/usr/share/rhn/server/rhnServer/server_wrapper.py", line 61, in
save_packages
    ret = self.save_packages_byid(self.server["id"], schedule=schedule)
  File "/usr/share/rhn/server/rhnServer/server_packages.py", line 172, in
save_packages_byid
    h.execute_bulk(package_data)
  File "/usr/share/rhn/server/rhnSQL/int_oracle.py", line 220, in __getattr__
    raise AttributeError, name
AttributeError: execute_bulk

Local variables by frame
Frame __getattr__ in /usr/share/rhn/server/rhnSQL/int_oracle.py at line 220
	                self = <type 'instance'> <OracleCursor object at 0xbe8f930>
	                name = <type 'str'> execute_bulk

Frame save_packages_byid in /usr/share/rhn/server/rhnServer/server_packages.py
at line 173
	               sysid = <type 'int'> 1000010003
	        package_data = <type 'dict'> {'a': ['i386'



This is same looking traceback as within bug 446087 - look like dupes of each
other. 
Comment 4 Miroslav Suchý 2008-05-19 11:07:45 EDT

*** This bug has been marked as a duplicate of 446087 ***

Note You need to log in before you can comment on or make changes to this bug.