Bug 445679 - Request for Enhancement: Add a line to rescue (disk) "Re-install Grub"
Request for Enhancement: Add a line to rescue (disk) "Re-install Grub"
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: firstaidkit (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Joel Andres Granados
Fedora Extras Quality Assurance
http://billlinux@rogers.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-08 10:09 EDT by Bill Case
Modified: 2008-08-07 13:17 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-07 13:17:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Case 2008-05-08 10:09:43 EDT
Description of problem:
Not my problem: But I blew my grub the other day.  Fixed it through the grub
shell myself.  I could do so because I had climed the grub learning curve a
couple of years ago.

But I thought there must be an easier way --particularly for people new to
Fedora or grub or people who are in a hurry we need a safe way to get their grub
re-installed at least to a default level.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info: What follows is a summary of exchanges on the users list:
> As I think about it, the Fedora 8 rescue disk starts with 5 options;
> 
> "
> Install or Upgrade existing system
> Install or Upgrade existing system (text mode)
> Rescue installed system
> Boot from local drive
> Memory test "
> 
> I am thinking of asking as a Request for Enhancement that a sixth rescue
> option line be added:
> 
> "Re-install Grub"
> 
> The reinstall grub option would just run Anaconda as far as grub
> installation and then quit before implementing reformatting or changing
> any other partition configurations.  No new kernels or other programs
> would be installed.
> 
> It seems quick and easy with little or no learning curve.  If more
> changes were wanted one of the other options could then be used instead.
>
Comment 1 Jeremy Katz 2008-05-08 10:19:07 EDT
This is one of the things that we're hoping to get with the integration of
firstaidkit into rescue mode
Comment 2 Joel Andres Granados 2008-05-09 04:32:20 EDT
this is a firstaidkit plugin that is being worked on.  It will be released
shortly with the new version of firstaidkit.  Changing the component so this
does not get ignore.
Comment 3 Joel Andres Granados 2008-08-07 13:17:03 EDT
This will be coming to fedora soon.   The grub plugin will make its appearance in f10.  you can checkitout in current git repo. https://fedorahosted.org/firstaidkit/ if you are impatient.  We do need some testing so feel free to open this bug again if the plugin fails miserably

Note You need to log in before you can comment on or make changes to this bug.