Bug 445701 - RFE for the ability to accept the defaults and begin install from the first menu/screen present to the enduser
RFE for the ability to accept the defaults and begin install from the first m...
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-08 12:15 EDT by Jóhann B. Guðmundsson
Modified: 2008-07-14 15:24 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-11 17:09:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jóhann B. Guðmundsson 2008-05-08 12:15:53 EDT
Description of problem:

End user gets himself a copy of fedora installation media
inserts it and boots from it and on the first menu/screen
the user sees two buttons [ Install ] [ Advanced Install ]

Something like this..

Welcome to anaconda Fedora's installer ( or some other text )

To install Fedora you need to...

Type first letter(s) in your country for keyboard layout [ input box ]

# There's absolutly no need to have a special menu/screen
   which lists all the country's

Type first letter(s) in your country for timezone [ input box ]

# Again no need to in this case have a map for the user to select where he is.

Encrypt partition [] 

Accept defaults and begin [ Install ]

# This would just auto select all defaults for the end user and
  up pops an dialog box where he's asked to provide root and enryption
  password. Same as pressing next next next done install..

For advanced user choose [ Advanced install ]

# This would just take the users through the current installation process.

There would be need for sanity checks which would pop up, 
warning box asking for user confirmation about what anaconda is about to do
or an question/msg box for the end user which anaconda would 
ask for user input on what to do next such as anaconda 
has detected previous ntfs partition resize or delete etc.

What would be gained by doing this.

Anaconda/Fedora would take the lead of being the most userfriendly 
linux distro to install, but still keeping all the advantages 
it has for it's advanced users.

This is as close as it can get to single <click> install as possible
( you could move the keyboard layout and timezone to firstboot, but
still the user would need to provide the password for root and encryption 
if the user choose to encrypt. )

And would be hard to for "unamed" and or other linux distro's/OS'es to beat this
in it's installation process. 

Thoughts comments well appreciated.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Chris Lumens 2008-07-11 17:09:02 EDT
We've had these sorts of options before - like allowing Workstation vs. Server
vs. Custom installation sets that offer different defaults, hide certain
screens, etc.  The problem we've noticed is that everyone thinks they want the
custom installation, or everyone thinks they are an advanced user.  So, we
removed the ability to choose those sorts of installation classes.  I predict
that something similar would happen here were we to offer a choice of accepting
all the defaults and installing vs. allowing specification of everything.

Instead, we are working on making it so the defaults are good throughout the
installation process so the user really just has to hit "Next" on each screen. 
This gives them the ability to review everything like we know they want to, but
not actually have to make tough changes.
Comment 2 Jóhann B. Guðmundsson 2008-07-11 20:13:12 EDT
Clumes My good man I'm not talking about server this or desktop that or NEXT
NEXT and so forth I'm talking about offering "novice" users the ability to
accept the default at first screen they see and provide the root password and
begin install and have and "Advanced" flip for the amateurs or experts or those
that can click next next or select any other settings than the defaults...

If you can Record your gram ma installing Fedora i'm a sold man but until then..

This one of the things that Anaconda has been criticized the most for, you and
Jeremy of all men should know that come on.. 
 
"Anaconda Installation is to targeted to much against advanced users"

Unleash your CODE OF POWER and show the world what the anaconda team is capably
of :) Target the little guy for once..  
Comment 3 Jóhann B. Guðmundsson 2008-07-11 20:26:22 EDT
Oh and another thing HAVE YOU TRIED IT UNTIL THEN TRY IT IF IT BECOMES FAILURE
THEN MAKE A MORTAR OUT OF THE EXAMPLE UNTIL THEN DONT MAKE THE ASSUMPTION IT FAILS..
Comment 4 Andy Lindeberg 2008-07-14 09:37:35 EDT
As Chris said, we have offered that sort of option before - not that exact
option, but that /sort/. And for whatever reason, be it because users don't like
to think of themselves as novices, or because they want the option to review
everything before making permanent changes, or because they do need to customize
certain screens, most people don't pick the automatic setups. We can see that
they don't from details in the exception reports.

So rather than make an option that the vast majority of people won't ever use,
it makes far more sense for us to ensure that the interface itself is
understandable and that most users can get the install they wanted merely by
clicking "Next" through the screens.
Comment 5 Jóhann B. Guðmundsson 2008-07-14 10:44:22 EDT
I have really a hard time believing this.

If a user is given Accept default and begin [ INSTALL ] 
that he would not accept that but rather choose and click 
[ Next ] [ Next ] etc.

I'm not talking about removing anaconda next next faze but
to offer something like ...

Accept default and begin [ INSTALL ] 
( User is asked for the root password Anaconda uses Next Next values and
proceeds with install ) 

Proceed to advanced [ Installation ]
( Anaconda install procedure as it is now ...)

Do you have any link to these "exception reports".

In what release was this option introduced?
Comment 6 Andy Lindeberg 2008-07-14 11:32:28 EDT
As I said, *this* option has not been included. However, in previous releases we
offered other, similar "default" options that were rarely used.

You can find exception reports attached to many bugzillas. If you want an
example of what one looks like, you can find one here:
https://bugzilla.redhat.com/attachment.cgi?id=310946

We understand what it is that you're suggesting, but, by and large, it's not an
option that would be used. People want to know what it is they are agreeing to
before making any permanent changes to their computers, and agreeing blindly to
the defaults doesn't give them that. Clicking through several screens takes a
little more time, but allows people to review everything and change whatever
they'd like.
Comment 7 Jóhann B. Guðmundsson 2008-07-14 12:22:54 EDT
<snip>
"As I said, *this* option has not been included"

"We understand what it is that you're suggesting, but, by and large, it's not an
option that would be used"
</snip>

If you have not tried it you cannot claim it does not work.

And I never was suggesting that the ability to configure and click next 
was removed just put under [Advanced]

The only thing this could be criticized for is it would be targeted against 
US based residents since everything defaults to US ( keyboard time-zone etc )

The other way to reduce the ADVANCED user label anaconda has is to put more
options to fewer menu/screens to make it more noob userfriendly without removing
any of the configuration options the user has.

The more option the user has the more questions come to his mind == more things
can go wrong.
Comment 8 Andy Lindeberg 2008-07-14 13:22:18 EDT
We cannot definitively state that it would not be a beloved feature that would
appeal to Fedora fans everywhere. Similarly, we cannot definitively state that
users wouldn't absolutely love it if we removed all languages except English
during the install, because we haven't done it. However, /based on past
experience/, we can predict with pretty good accuracy how people are going to
react to that kind of thing.

We understand exactly what you're suggesting, and from the experiences we have
had with users, it would not be a feature that people would use - regardless of
where you hide the next options.

I have to disagree with you about "more options on fewer screens" being at all
user-friendly. Squishing network configuration, time zone selection, and setting
the root password together onto one screen is a much more complicated interface
than having them spread out. The more options on a screen, the more confusing it
can be to a new user... but the fewer per screen, /regardless of the number of
screens/, the simpler it feels.

Not to mention, it's impossible to implement in text mode given the limited
amount of screen space available.
Comment 9 Jóhann B. Guðmundsson 2008-07-14 14:31:00 EDT
Again which release in which install of anaconda came with "close" to this but
not exact so I can test it and see for my self what possible went wrong and see
where the anaconda team is basing it's past experience/finding on.

I say try it, if it fails then make an example out if and definetly state
with accuracy that this does not work.

If you disagree with me with more option fewer screens then you must
agree with me 1 install option one screen does not get any simpler.

"Not to mention, it's impossible to implement in text mode given the limited
amount of screen space available."

If a noob user hit's text mode he's fucked everybody knows that.

Well then there's is nothing left but more easy to read/simplified text 
larger letter size and 30 screens with pictures to get the Anaconda is for the
advanced user label off.

Going to go through the install faze of suse mandrake and ubuntu to 
better grasp why people seem to come to that conclusion when reviewing 
Fedora.

Will post finding. 
Comment 10 Andy Lindeberg 2008-07-14 15:24:39 EDT
You can find one of our previous "default or custom" options in Fedora 4. :)

We are not going to implement a feature that will not be used and that we will
have to remove once it's clear that nobody uses it. We can already state with
high accuracy that it is not a needed feature.

I need not agree with you on that at all. The best interface for a user is one
where related options go on the same screen - UTC with time zone, all the
partitioning options together, all the packaging options together, all the
language options in a nice list. Having one option per screen might look simple,
but it is easy to forget what option you selected three screens ago that affects
the screen you're seeing.

Text mode is a perfectly usable interface, it just has less customization
capabilities. A new user using text mode is not automatically in trouble.
Regardless, we do not need to further divorce the two interfaces and their
capabilities.

If you really want to make the installation easier for people, then how about
this: Provide examples and screenshots of places where you think things are not
clear, and for which we have not provided adequate information. The
documentation for Fedora 9 can be found here:
http://docs.fedoraproject.org/install-guide/f9/en_US/

I'm sure you'll agree that even a n00b user can read documentation. :)

Note You need to log in before you can comment on or make changes to this bug.