Bug 445743 - crash when editing file name in 'save as' on first key press
crash when editing file name in 'save as' on first key press
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: libX11 (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Søren Sandmann Pedersen
Fedora Extras Quality Assurance
:
: 446486 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-08 16:25 EDT by Tom London
Modified: 2014-06-18 05:10 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-14 14:20:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
mapped stack (8.96 KB, text/plain)
2008-05-09 04:00 EDT, Caolan McNamara
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 508751 None None None Never

  None (edit)
Description Tom London 2008-05-08 16:25:25 EDT
Description of problem:
trying to save a sheet as csv and changing the name got the following crash

(I)    x.org loaded video driver of...
(II) Loading /usr/lib/xorg/modules/drivers//intel_drv.so
(II) Loading /usr/lib/xorg/modules/drivers//intel_master_drv.so
(II) Loading /usr/lib/xorg/modules/drivers//fbdev_drv.so
(II) Loading /usr/lib/xorg/modules/drivers//vesa_drv.so
(II) Unloading /usr/lib/xorg/modules/drivers//fbdev_drv.so
(II) Unloading /usr/lib/xorg/modules/drivers//vesa_drv.so
(==) Depth 24 pixmap format is 32 bpp
(III)  Desktop is: GNOME
(IV)   openoffice.org-kde version is: package openoffice.org-kde is not installed
(V)    libgcj version is: libgcj-4.3.0-8-i386
(IV)   kernel is: Linux 2.6.25-14.fc9.i686 #1 SMP Thu May 1 06:28:41 EDT 2008
i686 i686 i386
(VII)  OpenOffice.org core rpm version is: openoffice.org-core-2.4.0-12.8.fc9-i386
(VIII) accessibility is: false
(VIV)  fedora release is: Fedora release 9 (Sulphur)
(VV)   LANG is: en_US.UTF-8
...start free space details ...
Filesystem           1K-blocks      Used Available Use% Mounted on
/dev/mapper/VolGroup00-LogVol00
                      52752892  44664904   5365032  90% /
tmpfs                  1032972    344964    688008  34% /tmp
...end free space details ...
...start sestatus details ...
SELinux status:                 enabled
SELinuxfs mount:                /selinux
Current mode:                   enforcing
Mode from config file:          enforcing
Policy version:                 22
Policy from config file:        targeted
...end sestatus details ...
...start stackreport details ...
0x489d3e8: 0x1c4c7c: /usr/lib/openoffice.org/program/libuno_sal.so.3 + 0x253e8
0x489dd23: 0x1c4c7c: /usr/lib/openoffice.org/program/libuno_sal.so.3 + 0x25d23
0x110400: 0x0:  + 0x400 (__kernel_sigreturn + 0x0)
0xc866f4: 0x94978: /usr/lib/libgdk-x11-2.0.so.0 + 0x586f4
0xc785b5: 0x94978: /usr/lib/libgdk-x11-2.0.so.0 + 0x4a5b5
0xc78f3c: 0x94978: /usr/lib/libgdk-x11-2.0.so.0 + 0x4af3c
0xc7adb2: 0x94978: /usr/lib/libgdk-x11-2.0.so.0 + 0x4cdb2
0xc7af84: 0x94978: /usr/lib/libgdk-x11-2.0.so.0 + 0x4cf84
0x738098: 0xe0108: /lib/libglib-2.0.so.0 + 0x37098 (g_main_context_dispatch + 0x1e8)
0x73b743: 0xe0108: /lib/libglib-2.0.so.0 + 0x3a743
0x73bc62: 0xe0108: /lib/libglib-2.0.so.0 + 0x3ac62 (g_main_loop_run + 0x1d2)
0x4455439: 0x3fc9f8: /usr/lib/libgtk-x11-2.0.so.0 + 0xd3439 (gtk_dialog_run + 0x217)
0x1ec008c: 0x18a80: /usr/lib/openoffice.org/program/fps_gnome.uno.so + 0x708c
0x1ec00f9: 0x18a80: /usr/lib/openoffice.org/program/fps_gnome.uno.so + 0x70f9
0x7387c6: 0xe0108: /lib/libglib-2.0.so.0 + 0x377c6
0x738098: 0xe0108: /lib/libglib-2.0.so.0 + 0x37098 (g_main_context_dispatch + 0x1e8)
0x73b743: 0xe0108: /lib/libglib-2.0.so.0 + 0x3a743
0x73b901: 0xe0108: /lib/libglib-2.0.so.0 + 0x3a901 (g_main_context_iteration + 0x71)
0x26f827: 0x4b950: /usr/lib/openoffice.org/program/libvclplug_gtk680li.so + 0x11827
0x33b8b9: 0x7859c: /usr/lib/openoffice.org/program/libvclplug_gen680li.so +
0x4b8b9 (X11SalInstance::Yield(bool, bool) + 0x2f)
0x4c2acb9: 0x37e324: /usr/lib/openoffice.org/program/libvcl680li.so + 0x98cb9
(Application::Yield(bool) + 0x57)
0x5a69209: 0x37a7e0: /usr/lib/openoffice.org/program/libsfx680li.so + 0x1f8209
0x5a6a87e: 0x37a7e0: /usr/lib/openoffice.org/program/libsfx680li.so + 0x1f987e
0x5a6af4d: 0x37a7e0: /usr/lib/openoffice.org/program/libsfx680li.so + 0x1f9f4d
(sfx2::FileDialogHelper::Execute(SfxItemSet*&, String&) + 0x29)
0x59e3e1a: 0x37a7e0: /usr/lib/openoffice.org/program/libsfx680li.so + 0x172e1a
0x59e5040: 0x37a7e0: /usr/lib/openoffice.org/program/libsfx680li.so + 0x174040
0x59a9e04: 0x37a7e0: /usr/lib/openoffice.org/program/libsfx680li.so + 0x138e04
0x5a30ad4: 0x37a7e0: /usr/lib/openoffice.org/program/libsfx680li.so + 0x1bfad4
(SfxShell::ExecuteSlot(SfxRequest&, SfxInterface const*) + 0xb4)
0x76c8e7e: 0x9c2ea0: /usr/lib/openoffice.org/program/libsc680li.so + 0x1b2e7e
(ScTabViewShell::ExecuteSave(SfxRequest&) + 0x3a)
0x76bdc14: 0x9c2ea0: /usr/lib/openoffice.org/program/libsc680li.so + 0x1a7c14
0x5a246b8: 0x37a7e0: /usr/lib/openoffice.org/program/libsfx680li.so + 0x1b36b8
0x5a1cf9a: 0x37a7e0: /usr/lib/openoffice.org/program/libsfx680li.so + 0x1abf9a
0x5a3abd4: 0x37a7e0: /usr/lib/openoffice.org/program/libsfx680li.so + 0x1c9bd4
0x5a3b08e: 0x37a7e0: /usr/lib/openoffice.org/program/libsfx680li.so + 0x1ca08e
0x7143dd5: 0x25488c: /usr/lib/openoffice.org/program/libfwk680li.so + 0xb5dd5
0x7143e79: 0x25488c: /usr/lib/openoffice.org/program/libfwk680li.so + 0xb5e79
0x4c7c581: 0x37e324: /usr/lib/openoffice.org/program/libvcl680li.so + 0xea581
0x4d5027c: 0x37e324: /usr/lib/openoffice.org/program/libvcl680li.so + 0x1be27c
(Menu::Select() + 0x46)
0x4d48e38: 0x37e324: /usr/lib/openoffice.org/program/libvcl680li.so + 0x1b6e38
0x4d9d4ac: 0x37e324: /usr/lib/openoffice.org/program/libvcl680li.so + 0x20b4ac
0x33538a: 0x7859c: /usr/lib/openoffice.org/program/libvclplug_gen680li.so +
0x4538a (SalDisplay::DispatchInternalEvent() + 0x96)
0x26fa52: 0x4b950: /usr/lib/openoffice.org/program/libvclplug_gtk680li.so + 0x11a52
0x736181: 0xe0108: /lib/libglib-2.0.so.0 + 0x35181
0x738098: 0xe0108: /lib/libglib-2.0.so.0 + 0x37098 (g_main_context_dispatch + 0x1e8)
0x73b743: 0xe0108: /lib/libglib-2.0.so.0 + 0x3a743
0x73b901: 0xe0108: /lib/libglib-2.0.so.0 + 0x3a901 (g_main_context_iteration + 0x71)
0x26f827: 0x4b950: /usr/lib/openoffice.org/program/libvclplug_gtk680li.so + 0x11827
0x33b8b9: 0x7859c: /usr/lib/openoffice.org/program/libvclplug_gen680li.so +
0x4b8b9 (X11SalInstance::Yield(bool, bool) + 0x2f)
0x4c2acb9: 0x37e324: /usr/lib/openoffice.org/program/libvcl680li.so + 0x98cb9
(Application::Yield(bool) + 0x57)
0x4c2ad07: 0x37e324: /usr/lib/openoffice.org/program/libvcl680li.so + 0x98d07
(Application::Execute() + 0x2b)
0x7013933: 0x77340: /usr/lib/openoffice.org/program/libsoffice.so + 0x2f933
(desktop::Desktop::Main() + 0x1a0b)
0x4c2e2c2: 0x37e324: /usr/lib/openoffice.org/program/libvcl680li.so + 0x9c2c2
0x4c2e45e: 0x37e324: /usr/lib/openoffice.org/program/libvcl680li.so + 0x9c45e
(SVMain() + 0x2c)
0x7007f01: 0x77340: /usr/lib/openoffice.org/program/libsoffice.so + 0x23f01
(main + 0xe5)
0x52b5d6: 0x164d7c: /lib/libc.so.6 + 0x165d6 (__libc_start_main + 0xe6)
0x80484f1: 0x6dc: /usr/lib/openoffice.org/program/scalc.bin + 0x4f1 (main + 0x51)
...end stackreport details ...
...start sample ldd details ...
	linux-gate.so.1 =>  (0x00110000)
	libgtk-x11-2.0.so.0 => /usr/lib/libgtk-x11-2.0.so.0 (0x00513000)
	libgdk-x11-2.0.so.0 => /usr/lib/libgdk-x11-2.0.so.0 (0x00162000)
	libatk-1.0.so.0 => /usr/lib/libatk-1.0.so.0 (0x001f8000)
	libgdk_pixbuf-2.0.so.0 => /usr/lib/libgdk_pixbuf-2.0.so.0 (0x00215000)
	libpangocairo-1.0.so.0 => /usr/lib/libpangocairo-1.0.so.0 (0x00232000)
	libpango-1.0.so.0 => /usr/lib/libpango-1.0.so.0 (0x0023c000)
	libcairo.so.2 => /usr/lib/libcairo.so.2 (0x0027f000)
	libgmodule-2.0.so.0 => /lib/libgmodule-2.0.so.0 (0x002ee000)
	libdl.so.2 => /lib/libdl.so.2 (0x002f2000)
	libgthread-2.0.so.0 => /lib/libgthread-2.0.so.0 (0x002f7000)
	librt.so.1 => /lib/librt.so.1 (0x002fc000)
	libdbus-glib-1.so.2 => /usr/lib/libdbus-glib-1.so.2 (0x00306000)
	libdbus-1.so.3 => /lib/libdbus-1.so.3 (0x00324000)
	libgobject-2.0.so.0 => /lib/libgobject-2.0.so.0 (0x00365000)
	libglib-2.0.so.0 => /lib/libglib-2.0.so.0 (0x003a5000)
	libvclplug_gen680li.so =>
/usr/lib/openoffice.org/program/libvclplug_gen680li.so (0x00913000)
	libvcl680li.so => /usr/lib/openoffice.org/program/libvcl680li.so (0x00992000)
	libpsp680li.so => /usr/lib/openoffice.org/program/libpsp680li.so (0x00d18000)
	libsot680li.so => /usr/lib/openoffice.org/program/libsot680li.so (0x00486000)
	libutl680li.so => /usr/lib/openoffice.org/program/libutl680li.so (0x00df9000)
	libtl680li.so => /usr/lib/openoffice.org/program/libtl680li.so (0x00e7f000)
	libcomphelp4gcc3.so => /usr/lib/openoffice.org/program/libcomphelp4gcc3.so
(0x00f22000)
	libucbhelper4gcc3.so => /usr/lib/openoffice.org/program/libucbhelper4gcc3.so
(0x068f0000)
	libuno_cppuhelpergcc3.so.3 =>
/usr/lib/openoffice.org/program/libuno_cppuhelpergcc3.so.3 (0x06eae000)
	libuno_cppu.so.3 => /usr/lib/openoffice.org/program/libuno_cppu.so.3 (0x06099000)
	libvos3gcc3.so => /usr/lib/openoffice.org/program/libvos3gcc3.so (0x05f5e000)
	libuno_sal.so.3 => /usr/lib/openoffice.org/program/libuno_sal.so.3 (0x02adb000)
	libX11.so.6 => /usr/lib/libX11.so.6 (0x07d72000)
	libXext.so.6 => /usr/lib/libXext.so.6 (0x004e4000)
	libpthread.so.0 => /lib/libpthread.so.0 (0x05dba000)
	libstlport_gcc.so => /usr/lib/openoffice.org/program/libstlport_gcc.so (0x07610000)
	libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0x07b65000)
	libm.so.6 => /lib/libm.so.6 (0x05fea000)
	libgcc_s.so.1 => /lib/libgcc_s.so.1 (0x05c39000)
	libc.so.6 => /lib/libc.so.6 (0x01d13000)
	libXcomposite.so.1 => /usr/lib/libXcomposite.so.1 (0x05ab8000)
	libXfixes.so.3 => /usr/lib/libXfixes.so.3 (0x05afe000)
	libpng12.so.0 => /usr/lib/libpng12.so.0 (0x05fa4000)
	libfontconfig.so.1 => /usr/lib/libfontconfig.so.1 (0x0101f000)
	libXrender.so.1 => /usr/lib/libXrender.so.1 (0x05b8a000)
	libXinerama.so.1 => /usr/lib/libXinerama.so.1 (0x0104e000)
	libXi.so.6 => /usr/lib/libXi.so.6 (0x04a4e000)
	libXrandr.so.2 => /usr/lib/libXrandr.so.2 (0x04a18000)
	libXcursor.so.1 => /usr/lib/libXcursor.so.1 (0x04a69000)
	libpangoft2-1.0.so.0 => /usr/lib/libpangoft2-1.0.so.0 (0x04dc9000)
	libfreetype.so.6 => /usr/lib/libfreetype.so.6 (0x05870000)
	libz.so.1 => /lib/libz.so.1 (0x04b77000)
	libpixman-1.so.0 => /usr/lib/libpixman-1.so.0 (0x04e1a000)
	libselinux.so.1 => /lib/libselinux.so.1 (0x04c4f000)
	/lib/ld-linux.so.2 (0x004f5000)
	libnsl.so.1 => /lib/libnsl.so.1 (0x04c19000)
	libcap.so.2 => /lib/libcap.so.2 (0x049c7000)
	libSM.so.6 => /usr/lib/libSM.so.6 (0x01051000)
	libICE.so.6 => /usr/lib/libICE.so.6 (0x0105a000)
	libi18nisolang1gcc3.so =>
/usr/lib/openoffice.org/program/libi18nisolang1gcc3.so (0x049fd000)
	libbasegfx680li.so => /usr/lib/openoffice.org/program/libbasegfx680li.so
(0x0526d000)
	libicuuc.so.38 => /usr/lib/libicuuc.so.38 (0x069d7000)
	libicule.so.38 => /usr/lib/libicule.so.38 (0x04f28000)
	libjvmaccessgcc3.so.3 => /usr/lib/openoffice.org/program/libjvmaccessgcc3.so.3
(0x01074000)
	libjvmfwk.so.3 => /usr/lib/openoffice.org/program/libjvmfwk.so.3 (0x04c34000)
	libuno_salhelpergcc3.so.3 =>
/usr/lib/openoffice.org/program/libuno_salhelpergcc3.so.3 (0x01968000)
	libcrypt.so.1 => /lib/libcrypt.so.1 (0x01b62000)
	libxcb-xlib.so.0 => /usr/lib/libxcb-xlib.so.0 (0x01952000)
	libxcb.so.1 => /usr/lib/libxcb.so.1 (0x01a70000)
	libXau.so.6 => /usr/lib/libXau.so.6 (0x0195d000)
	libexpat.so.1 => /lib/libexpat.so.1 (0x01ae9000)
	libicudata.so.38 => /usr/lib/libicudata.so.38 (0xb75f3000)
	libxml2.so.2 => /usr/lib/libxml2.so.2 (0x027a1000)
	libXdmcp.so.6 => /usr/lib/libXdmcp.so.6 (0x0197e000)
...end sample ldd details ...

Version-Release number of selected component (if applicable):
openoffice.org-calc-2.4.0-12.8.fc9.i386

How reproducible:
do not know

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Caolan McNamara 2008-05-09 03:51:59 EDT
I guess this doesn't happen every time, but just the once. 

At what point did it crash do you remember, did the dialog appear ? And did it
crash only after clicking ok or before ?
Comment 2 Caolan McNamara 2008-05-09 04:00:24 EDT
Created attachment 304927 [details]
mapped stack

Hmm, looks rather odd to me, mostly in gdk i.e. crash after
translate_key_event->_gdk_keymap_key_is_modifier
Comment 3 Caolan McNamara 2008-05-09 04:30:35 EDT
I suspect that this isn't specific to OOo.

I wonder if it crashed on the first key press you entered ?
Comment 4 Tom London 2008-05-09 09:25:40 EDT
Sorry for the incomplete description.

Here is what I remember:

I clicked on "Save As...." and the dialog popped up.

I clicked on the selector for file type (I was trying to see if there were
several choices for ".csv", e.g., comma separated, tab separated, ....), but saw
there was only one.

I think I "opened" the file type "triangle thing" on the lower left (that shows
files types too).

I then tried to add a letter to the file name, so as not to clobber the already
existing .csv file.

It then crashed.

I tried to recreate, but could not.
Comment 5 Caolan McNamara 2008-05-09 09:49:13 EDT
I don't see anything under valgrind.

But the report of a crash on the 1st keypress in the file dialog and stacktrace
tallies with the upstream gnome report at
http://bugzilla.gnome.org/show_bug.cgi?id=508751
Comment 6 Tom London 2008-05-09 10:11:17 EDT
Hmmm... May be a different issue, but I have noticed that my gnome apps do
sometimes lose the ability to see SHIFT and CNTL key presses: in gnome-terminal
windows (and I believe firefox, etc.) "d" and "SHIFT-d" and "CNTL-d" all act
like I entered "d". Surprisingly, all seems to work OK in my VMWare window.

I had this issue yesterday at about 13:28PM PST (as indicated by "last", as I
had to log out and log back in again to recover keyboard functions).

I filed this bug at 16:25 PM EST, and I believe I had to use mouse functions to
complete the report (e.g., right-click COPY, right-click PASTE).
Comment 7 Bug Zapper 2008-05-14 06:51:39 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 8 Matthias Clasen 2008-06-16 22:00:23 EDT
Assuming this is in fact the 'crash on keypress if modifiermap is empty' bug in 
http://bugzilla.gnome.org/show_bug.cgi?id=508751
then this is really an X bug. 

If the modifier map is empty, then 

XkbGetMap (display, XkbModifierMapMask, XkbUseCoreKbd) 

doesn't allocate the modmap member of the client map. This is because 
_XkbReadModifierMap only allocates if rep->totalModMapKeys>0. And 
totalModMapKeys is zero if there are no modifier keys. 

I can work around this inside GTK+, but it should probably be fixed in XKB. 
Comment 9 Matěj Cepl 2008-06-17 08:36:24 EDT
*** Bug 446486 has been marked as a duplicate of this bug. ***
Comment 10 Bug Zapper 2009-06-09 20:41:40 EDT
This message is a reminder that Fedora 9 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 9.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '9'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 9's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 9 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 11 Bug Zapper 2009-07-14 14:20:37 EDT
Fedora 9 changed to end-of-life (EOL) status on 2009-07-10. Fedora 9 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.