Bug 445749 - [python client] kerberos based authentication
[python client] kerberos based authentication
Status: CLOSED ERRATA
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: python-qpid (Show other bugs)
1.1
All Linux
high Severity high
: 1.3
: ---
Assigned To: Ted Ross
Frantisek Reznicek
: FutureFeature
Depends On: 472519 581807
Blocks: 486202
  Show dependency treegraph
 
Reported: 2008-05-08 16:42 EDT by Gordon Sim
Modified: 2015-11-15 19:05 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
The Messaging Client Python API for Red Hat Enterprise Linux 5 now supports SASL Kerberos authentication.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-10-14 12:10:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gordon Sim 2008-05-08 16:42:20 EDT
Client should be updated to support kerberos.
Comment 7 Ted Ross 2009-11-11 12:34:45 EST
Implemented upstream at revision 834975.
Comment 8 Frantisek Reznicek 2010-04-14 08:33:30 EDT
The feature seems to be implemented on RHEL5 i386 / x86_64, not implemented/supported on RHEL 4.

At the moment (Alpha3 packages) feature is not functional, so I delay this BZ until bug 580597 and bug 581807 are resolved.
Comment 9 Frantisek Reznicek 2010-04-23 05:04:36 EDT
At the moment (beta1 packages) feature is still not functional, because of bug 581807. Waiting for bug 581807 resolution.

Feel free to raise objection about dependency on bug 581807 although I believe the dependency is evident.
Comment 10 Frantisek Reznicek 2010-04-26 05:19:03 EDT
The feature is implemented and functional, tested on RHEL 5.5 i386 / x86_64 on packages:
[root@mrg-qe-02 qpid_ptest_authentication_krb5]# [root@mrg-qe-02 1]# rpm -qa | grep -E '(qpid|sasl)' | sort -u
cyrus-sasl-2.1.22-5.el5_4.3
cyrus-sasl-devel-2.1.22-5.el5_4.3
cyrus-sasl-gssapi-2.1.22-5.el5_4.3
cyrus-sasl-lib-2.1.22-5.el5_4.3
cyrus-sasl-plain-2.1.22-5.el5_4.3
python-qpid-0.7.934605-1.el5
python-saslwrapper-0.1.934605-1.el5
qpid-cpp-client-0.7.935473-1.el5
qpid-cpp-client-devel-0.7.935473-1.el5
qpid-cpp-client-devel-docs-0.7.935473-1.el5
qpid-cpp-client-ssl-0.7.935473-1.el5
qpid-cpp-mrg-debuginfo-0.7.935473-1.el5
qpid-cpp-server-0.7.935473-1.el5
qpid-cpp-server-cluster-0.7.935473-1.el5
qpid-cpp-server-devel-0.7.935473-1.el5
qpid-cpp-server-ssl-0.7.935473-1.el5
qpid-cpp-server-store-0.7.935473-1.el5
qpid-cpp-server-xml-0.7.935473-1.el5
qpid-java-client-0.7.934605-1.el5
qpid-java-common-0.7.934605-1.el5
qpid-tests-0.7.930108-1.el5
qpid-tools-0.7.934605-2.el5
ruby-qpid-0.7.935473-1.el5
ruby-saslwrapper-0.1.934605-1.el5
saslwrapper-0.1.934605-1.el5
saslwrapper-devel-0.1.934605-1.el5

RHEL 4 python client does not support SASL kerberos authentication.
Reviewed with Gordon that mrg-rhel5-bug should be set to highlinght that feature is RHEL5 only.

-> VERIFIED
Comment 11 Douglas Silas 2010-10-07 12:00:08 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
The Messaging Client Python API for Red Hat Enterprise Linux 5 now supports SASL Kerberos authentication.
Comment 13 errata-xmlrpc 2010-10-14 12:10:32 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHSA-2010-0773.html

Note You need to log in before you can comment on or make changes to this bug.