Bug 445776 - /{var,usr} fail to mount early enough under iscsi root because are marked _netdev
/{var,usr} fail to mount early enough under iscsi root because are marked _ne...
Status: CLOSED DUPLICATE of bug 485478
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: anaconda (Show other bugs)
5.1
All Linux
medium Severity high
: rc
: ---
Assigned To: Anaconda Maintenance Team
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-08 21:18 EDT by Kostas Georgiou
Modified: 2009-09-02 16:53 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-02 16:53:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kostas Georgiou 2008-05-08 21:18:17 EDT
On a clean 5.1 install if /var is a seperate partition anaconda creates an fstab
like: /dev/rootvg/varlogvol   /var/log                ext3    defaults,_netdev 1 2

This has the result of /var getting mounted much later in the boot sequence and
you get errors like the following:
Setting clock  (utc): Fri May  9 01:44:57 BST 2008 [  OK  ]
Starting udev: [  OK  ]
Setting hostname foobar.localhost:  [  OK  ]
Setting up Logical Volume Management:   7 logical volume(s) in volume group
"rootvg" now active [  OK  ]
Checking filesystems
Checking all file systems. [  OK  ]
Remounting root filesystem in read-write mode:  [  OK  ]
Mounting local filesystems:  [  OK  ]
Enabling local filesystem quotas:  [  OK  ]
touch: cannot touch `/var/lib/random-seed': No such file or directory
chmod: cannot access `/var/lib/random-seed': No such file or directory
/etc/rc.d/rc.sysinit: line 849: /var/run/utmp: No such file or directory
touch: cannot touch `/var/log/wtmp': No such file or directory
....
Starting NFS statd: statd: Could not chdir: No such file or directory [FAILED]
Starting system message bus: Could not create file /var/lib/dbus/machine-id: No
such file or directory
Failed to start message bus: Failed to bind socket
"/var/run/dbus/system_bus_socket": No such file or directory [FAILED]
....
Checking network-attached filesystems
...
/dev/rootvg/varvol: clean, 312/1048576 files, 108548/1048576 blocks
....

Bug #244994 is responsible for the change but it's not clear why the change was
introduced since the bug #238143 isn't visible.

It's been a while since I tried 5.0 but I am pretty sure that it worked fine
there so this is a regression.
Comment 1 Chris Lumens 2009-09-02 16:53:10 EDT

*** This bug has been marked as a duplicate of bug 485478 ***

Note You need to log in before you can comment on or make changes to this bug.