Bug 445779 - yum behind captive AP throws UnicodeDebugError
yum behind captive AP throws UnicodeDebugError
Status: CLOSED DUPLICATE of bug 446248
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-08 21:35 EDT by Matt Domsch
Modified: 2014-01-21 18:02 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-14 00:55:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
yum-behind-fonap.txt (8.69 KB, text/plain)
2008-05-08 21:35 EDT, Matt Domsch
no flags Details

  None (edit)
Description Matt Domsch 2008-05-08 21:35:53 EDT
Description of problem:
<mdomsch> scenario: yum downloads metadata (or tries to) while behind some
captive access point
<mdomsch> the AP lies and says "sure, here's the mirrorlist"
<mdomsch> when in fact what you got was the AP's welcome page
<mdomsch> packagekitd segfaults
<mdomsch> from this
<mdomsch> yum clean metadata, after getting past the AP's welcome page, is needed
<skvidal> okay
<skvidal> so yum's doing the right thing in that case
<skvidal> bitching about the content of the mirrorlist
<skvidal> the issue you're seeing is
<skvidal> python's $$^$^#@!$#@!$ unicode support bitching b/c of the different
encodings
<skvidal> mdomsch: please file it, we'll fix the error message
<skvidal> we just have to tell it to encode/decode that string
<skvidal> it's not the end of the world
<skvidal> just very irritating
<mdomsch> thought you'd appreciate it
<mdomsch> always trying to brighten your world - that's me :-)
<skvidal> mdomsch: you see how it is trying to raise properly?
<mdomsch> yep

Version-Release number of selected component (if applicable):
yum-3.2.14-10.fc9.noarch

How reproducible:
always

Steps to Reproduce:
1. connect to the network behind a FON captive access point
2. yum update
  
Actual results:
backtrace

Expected results:
no backtrace; fail to update naturally.
Comment 1 Matt Domsch 2008-05-08 21:35:53 EDT
Created attachment 304919 [details]
yum-behind-fonap.txt
Comment 2 James Antill 2008-05-14 00:55:36 EDT

*** This bug has been marked as a duplicate of 446248 ***
Comment 3 Bug Zapper 2008-05-14 06:52:41 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Note You need to log in before you can comment on or make changes to this bug.