Bug 44580 - ntp started too early
Summary: ntp started too early
Status: CLOSED DUPLICATE of bug 46464
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: ntp   
(Show other bugs)
Version: 1.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-06-14 13:58 UTC by Jonathan Kamens
Modified: 2007-04-18 16:33 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-06-15 13:31:30 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jonathan Kamens 2001-06-14 13:58:30 UTC
The chkconfig line in /etc/rc.d/init.d/ntpd in ntp-4.0.99k-17 starts ntpd
well before named.  This is a problem when it tries to resolve the host
names in /etc/ntp/step-tickers.

Even if you change it to start at position 58 instead of position 26, which
I've done, you still have a problem -- named may not actually be finished
initializing when the ntpd script runs ntpdate, in which case the ntpdate
will fail because it can't resolve the host names in
/etc/ntp/step-tickers.  I'm not sure what, if anything, can be done about
this, short of modifying the named script to wait until it's listening (or
until some reasonably short timeout value) before exiting.

Comment 1 Harald Hoyer 2001-06-15 10:15:11 UTC
what about numeric ip adresses?


Comment 2 Jonathan Kamens 2001-06-15 13:31:26 UTC
Numeric IP addresses are a workaround, not a solution.  I have no control over
or advance warning when one of my step-tickers changes its IP address.


Comment 3 Pekka Savola 2001-07-19 12:37:29 UTC
Even though this was reported earlier, marking it duplicate of the same issue
reported on RHL71 (as people tend to check out that Product for known bugs).


Adjusting the start position is always a balance.  You could argue that it is
important
that the start times of daemons are _right_ in the logs, and that you can't
depend on
the DNS when starting the servers _anyway_ (test this via plugging out the cable 
before booting).

Nevertheless, I agree that the advantages of postponing ntpd probably outweigh
the disadvantages.


*** This bug has been marked as a duplicate of 46464 ***


Note You need to log in before you can comment on or make changes to this bug.