Bug 445885 - make target clean does not work, missing .cvsignore file
make target clean does not work, missing .cvsignore file
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: rhnlib (Show other bugs)
4.7
All Linux
low Severity low
: rc
: ---
Assigned To: Pradeep Kilambi
: EasyFix, Patch, Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-09 12:31 EDT by Michal Nowak
Modified: 2013-03-07 21:04 EST (History)
1 user (show)

See Also:
Fixed In Version: RHBA-2008-0777
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-24 16:06:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Make clean target working without relying on CVS infrastructure in source tarball (208 bytes, patch)
2008-05-09 12:31 EDT, Michal Nowak
no flags Details | Diff
Make clean target working without relying on CVS infrastructure in source tarball (208 bytes, patch)
2008-05-09 12:39 EDT, Michal Nowak
no flags Details | Diff

  None (edit)
Description Michal Nowak 2008-05-09 12:31:39 EDT
Description of problem:

In revision 9 of rhnlib-2.1.2 the target clean of Makefile in test/ directory
fails to works simply because the file .cvsignore is missing in this revision,
in revision 8 is included.

Please, provide that file back or, preferably, use attached patch to get rid of
that. From my POV having in source package parts of CVS infrastructure is weird
solution.
Comment 1 Michal Nowak 2008-05-09 12:31:39 EDT
Created attachment 304963 [details]
Make clean target working without relying on CVS infrastructure in source tarball
Comment 2 Michal Nowak 2008-05-09 12:39:11 EDT
Created attachment 304964 [details]
Make clean target working without relying on CVS infrastructure in source tarball

Sorry for the bad one, this is the right one.
Comment 4 Michal Nowak 2008-05-12 10:50:25 EDT
It's pretty easy to reproduce it. 

1) Install srpm package if current release 2.1.2-9

2) go to /usr/src/redhat/SOURCES/ and unpack the rhnlib-2.1.2.tar.gz and go to
test/ directory. There's no .cvsignore file which is mentioned in clean target
of test/Makefile.

clean:
        @rm -fv `cat .cvsignore`

I guess the file is in CVS but not in tarball (from my POV creating tarball via
CVS does not copy it's repository structure like .CVS/ and .cvsignore).
Comment 5 RHEL Product and Program Management 2008-05-12 16:55:19 EDT
This bugzilla has Keywords: Regression.  

Since no regressions are allowed between releases, 
it is also being proposed as a blocker for this release.  

Please resolve ASAP.
Comment 11 errata-xmlrpc 2008-07-24 16:06:59 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0777.html

Note You need to log in before you can comment on or make changes to this bug.