Bug 4459 - apachectl isn't included
Summary: apachectl isn't included
Status: CLOSED NEXTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: apache (Show other bugs)
(Show other bugs)
Version: 6.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Preston Brown
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-08-10 12:04 UTC by Mads Kiilerich
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-09-09 19:16:11 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Mads Kiilerich 1999-08-10 12:04:34 UTC
- even though the man-page is.

A couple of comments while mangling with the .spec:

Why is log and modules located under /etc/httpd? It would be
more RedHatStandard if the config-files was located directly
under /etc/httpd instead of in the conf subdirectory.

Why keep separate src, access and httpd config files when
apache suggests using only httpd?

Regards
Kiilerich

Comment 1 Preston Brown 1999-08-18 19:53:59 UTC
we will remove the man page.  the functionality is provided by
/etc/rc.d/init.d/httpd.  The files are layed out as they are for
historical reasons.  We could move them around a bit but it would
produce problems for long-time apache users on Red Hat. Same goes for
the config files, but we will be migrating to a unified config file in
our next release of apache, and providing empty access and srm config
files for compatibility.

Comment 2 mgrier 1999-09-01 00:27:59 UTC
I don't understand the reasoning behind this decision. If you don't
have apachectl to shut down and restart the server, don't you have to
reboot? I just want to make changes to the config files. Having to
reboot seems like overkill.

Mike

Comment 3 Mads Kiilerich 1999-09-01 08:24:59 UTC
Use
/etc/rc.d/init.d/httpd reload
or
... restart

Apachectl is just "the apache way to do it". .../httpd does the same.
[pbrown: I can not unselect "Reopen bug" just below this "additional
comments" field. Sorry]Use
/etc/rc.d/init.d/httpd reload
or
... restart

Apachectl is just "the apache way to do it". .../httpd does the same.
[pbrown: I can not unselect "Reopen bug" just below this "additional
comments" field. Sorry]

Comment 4 Preston Brown 1999-09-09 19:16:59 UTC
removed man page for next release.

Comment 5 Michael G Schwern 1999-09-28 20:22:59 UTC
Please reinstate apachectl to the apache package.

Why???

* Don't reinvent the wheel *
Wouldn't it be easier for /etc/rc.d/init.d/httpd to just call
apachectl?

* init.d/httpd doesn't do everything that apachectl does *
Things which apachectl does that /etc/rc.d/init.d/httpd does not:
	Graceful server restart (send SIGUSR1)  *This is very important*
	Configuration test				*This is also very important*
	Differenciate between status and fullstatus  *Not a big deal*

* Backwards and Cross-Distribution/Unix Compatibility *
Even if /etc/rc.d/init.d/httpd evolves to completely take over
apachectl's functionality, apachectl should still not be removed.
Many programs will expect it to be there and want to use it, programs
written for older versions of Redhat, those written for other Linux
distributions and those written for other Unixes.  For finding,
querying and controlling apache, apachectl is your most compatible
bet.


Any one of the above three are valid arguments against removing
apachectl.  Maybe you can just add a SEE ALSO to the apachectl man
page pointing users at /etc/init.d/rc.d/httpd.


Note You need to log in before you can comment on or make changes to this bug.