Bug 445900 - [Stratus 5.6 bug] grub gets confused and fails to boot if a USB drive is present when booting from a disk
[Stratus 5.6 bug] grub gets confused and fails to boot if a USB drive is pres...
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: grub (Show other bugs)
5.4
x86_64 Linux
high Severity high
: rc
: 5.6
Assigned To: Peter Jones
: OtherQA, Reopened
Depends On:
Blocks: 557597
  Show dependency treegraph
 
Reported: 2008-05-09 14:23 EDT by Charlotte Richardson
Modified: 2010-08-09 15:59 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-09 15:59:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Charlotte Richardson 2008-05-09 14:23:55 EDT
Description of problem:
If you have a USB drive plugged in when booting from disk, grub at first finds
the disk as the boot media, but then gets confused by the presence of the USB
device and reports a "geometry error" and fails to boot.

Version-Release number of selected component (if applicable):
At least RHEL4U5 and later, currently on RHEL5.2.

How reproducible:
Always.

Steps to Reproduce:
1. Plug a (nonbootable) USB thumb drive in.
2. Attempt to boot from disk.

Actual results:
Starts to boot, gets confused by the USB dirve, and reports a "geometry error".
You must remove the USB device in order to boot.

Expected results:
Should successfully boot from the disk.

Additional info:
Comment 1 Denise Dumas 2009-03-13 14:42:08 EDT
We're not going to have time to get to this in 5.4 so I'm moving it to 5.5 (Hi Charlotte!)
Comment 3 RHEL Product and Program Management 2009-12-22 12:09:56 EST
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".
Comment 4 Peter Jones 2009-12-22 14:55:28 EST
I don't think this is a bug - when you install the bootloader, it is set up to use a specific drive based on the BIOS drive number (i.e. 0x80).  If you add a device after that and BIOS re-enumerates the devices with the new device before the old one, that simply won't work.  This appears to be either user error or a BIOS bug.
Comment 5 Charlotte Richardson 2010-01-22 14:59:28 EST
I disagree, and would like to reopen this bug because we have still gotten complaints about it under RHEL5.4. Any system using grub for its boot-loader that I have tried this on behaves in the same way. Grub will get confused and the system will not boot if a USB thumb drive happens to be plugged in when the system is rebooted, even though the BIOS is set to boot from disk and the USB drive is not bootable. For example, it reproduces on an Intel S5500BC motherboard with two quad-core X5570 2.93GHz processor chips that I happen to have here, as well as various standard Dell platforms. If you happen to have left a USB thumb drive plugged in and the system needs to reboot for any reason, grub will get confused and the system will never boot up, until you physically go over to it and pull out the thumb drive. The BIOS is not involved. Grub starts running looking at the actual boot disk, gets confused, and then gets a "geometry error" looking at the USB drive instead of the boot disk.

/Charlotte
Comment 6 Andrius Benokraitis 2010-01-22 15:07:01 EST
Reopening per Partner request. We are very late in the 5.5 dev cycle though.
Comment 7 Andrius Benokraitis 2010-01-27 13:40:51 EST
Escalating to RH mgmt.
Comment 8 Alexander Todorov 2010-01-28 03:25:45 EST
@Status

We need to confirm that there is third-party commitment to 
test for the resolution of this request during the RHEL 5.5 
Beta Test Phase before we can approve it for acceptance 
into the release.

RHEL 5.5 Beta Test Phase is expected to begin around February
2010.

In order to avoid any unnecessary delays, please post a 
confirmation as soon as possible, including the contact 
information for testing engineers.

Any additional information about alternative testing variations we 
could use to reproduce this issue in-house would be appreciated.
Comment 9 Charlotte Richardson 2010-01-28 08:52:45 EST
Stratus will test it.
Comment 10 Andrius Benokraitis 2010-02-17 15:13:28 EST
Deferring to RHEL 5.6, we ran out of time/resources this go around unfortunately and it sounds like you have a workaround in the meantime.
Comment 13 RHEL Product and Program Management 2010-08-09 14:55:19 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 14 Andrius Benokraitis 2010-08-09 15:17:19 EDT
Status: This is another RHEL 5 item that will most likely never make it in. It was rejected for RHEL 5.6 I don't see that changing for future minor releases. Your feedback is requested knowing this info.
Comment 15 Robert N. Evans 2010-08-09 15:55:11 EDT
This problem is not a showstopper for Stratus.  It is acceptable if this bug is never fixed.

Note You need to log in before you can comment on or make changes to this bug.