Bug 445953 - arabic/hindi numbers instead of decimal numbers
arabic/hindi numbers instead of decimal numbers
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
9
All Linux
low Severity high
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-10 07:09 EDT by Oron Peled
Modified: 2008-07-31 23:49 EDT (History)
1 user (show)

See Also:
Fixed In Version: 2.4.1-17.3.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-11 00:39:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Oron Peled 2008-05-10 07:09:25 EDT
Description of problem:

1. This is a regression in .doc filters that makes OO.o *unusable* for
   Hebrew.
2. The regression was introduced into OO.o-2.4.0, it is fixed for 2.4.1:
     http://qa.openoffice.org/issues/show_bug.cgi?id=86811
3. Because it was handled very late (April), F9 carries an unfixed
   version. Distro maintainers tried to handle it themselves:
     * Debian, lenny, OO.o 1:2.4.0-4 - On 22 April.
     * Ubuntu, Hardy, fixed:
         https://bugs.launchpad.net/ubuntu/+source/openoffice.org/+bug/210204
     * Mandrake, fixed according to user reports.
4. The easiest fix (IMO) is just pulling out the (very small) offending
   patch (that's what Debian did). Here is an example of the fix from
   archlinux:
     http://bugs.archlinux.org/task/10193?getfile=2032

I know it's bad timing, but since Fedora-9 carries the buggy version (only),
it's really a F9 killer here in Israel.
Comment 1 Caolan McNamara 2008-05-12 04:45:35 EDT
Hmm, I think its too late for F-9, but we can put it in the first update.

This affects binary .doc import for digits in CTL languages where they are
always converted, where the desire was to do it just for Arabic languages.

Will be in >= openoffice_org-2.4.0-12.9.fc9
Comment 2 Bug Zapper 2008-05-14 06:57:27 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 Fedora Update System 2008-06-09 05:37:39 EDT
openoffice.org-2.4.1-17.3.fc9 has been submitted as an update for Fedora 9
Comment 4 Fedora Update System 2008-06-09 23:14:56 EDT
openoffice.org-2.4.1-17.3.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update openoffice.org'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-5143
Comment 5 Fedora Update System 2008-06-11 00:38:46 EDT
openoffice.org-2.4.1-17.3.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 6 lihuang 2008-07-31 23:49:29 EDT
This bug has been verified with version openoffice.org-2.4.1-17.4.fc9.i386.rpm

Note You need to log in before you can comment on or make changes to this bug.