Bug 445955 - Configuring an HP printer appears to work but doesn't print
Configuring an HP printer appears to work but doesn't print
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: PackageKit (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Robin Norwood
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-10 08:48 EDT by Leslie Brooks
Modified: 2008-06-03 10:49 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-03 10:49:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Printer debug log (6.20 KB, text/plain)
2008-05-10 08:48 EDT, Leslie Brooks
no flags Details

  None (edit)
Description Leslie Brooks 2008-05-10 08:48:23 EDT
Description of problem:
 I installed Fedora 9 Preview and ran system-config-printer; it found my HP6800
printer on the network and installed the driver but:

 1) did not install HPIJS.  

Attempting to print generated a troubleshooting dialog that quickly diagnosed
the problem and gave me an 'Install' option.  However, 

 2) clicking 'Install' gave no feedback at all that HPIJS had been installed or
had failed to install.  I think it failed because 'rpm -qa | grep -i hpijs'
returns nothing and because PackageKit says:
   "Null
    Waiting for other tasks to complete: HPIJS
    Waiting for other tasks to complete"

At the 'Install' step I believe I:
 a) Clicked 'Install'
 b) Clicked 'Forward'
 c) Clicked 'Back'
 d) Clicked 'Install' again
 e) Finally clicked 'Forward' all the way through to the end.

Version-Release number of selected component (if applicable):
0.7.82.2

How reproducible:
 I will delete the printer, reboot, try it again, and update this bug report.

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:
 Installing the printer should automatically install the required packages (in
this case HPIJS) along with the driver.  I really thought that it did install
HPIJS in a previous version; maybe I am wrong.

 In addition, clicking 'Install' should provide some feedback for success or
failure.

Additional info:
Comment 1 Leslie Brooks 2008-05-10 08:48:24 EDT
Created attachment 305020 [details]
Printer debug log
Comment 2 Leslie Brooks 2008-05-10 21:35:58 EDT
I rebooted and tried again and it worked fine.  I tried every abnormal
combination I could think of at the 'Install' button, but every time I clicked
it, regardless of what I did before or after, it prompted me for the root
password (which it did NOT do yesterday).

So, perhaps this bug really belongs to Packagekit, and should be marked
'Intermittent' or 'Rare'.
Comment 3 Tim Waugh 2008-05-12 05:01:26 EDT
system-config-printer just runs system-install-packages to install drivers, and
that's now part of PackageKit.  Reassigning.
Comment 4 Robin Norwood 2008-05-12 12:54:02 EDT
One possibility is that if you were doing something else with the packaging
system (like running yum from the commandline, or something else to lock yum or
the rpmdb), PackageKit may have been waiting until it could get a lock.  Of
course we should be handling that case smoothly, but there might be some cases
where we aren't.
Comment 5 Leslie Brooks 2008-05-12 19:00:15 EDT
I am quite sure that I wasn't running yum; I know that yum and PackageKit
conflict and I would have known what was causing the problem.  Also, that system
has Beta installed on it and I am planning to install Preview over the top of
it; I wouldn't bother installing or updating any programs on it.
Comment 6 Bug Zapper 2008-05-14 06:57:39 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 7 Richard Hughes 2008-05-15 03:20:26 EDT
system-config-printer runs as the root user, right? If so,
http://fedoraproject.org/wiki/PackageKitFaq might be coming into effect.
Comment 8 Tim Waugh 2008-05-15 03:42:08 EDT
(In reply to comment #7)
> system-config-printer runs as the root user, right?

No, it doesn't.
Comment 9 Richard Hughes 2008-05-28 05:28:50 EDT
Leslie, did you try to install the printer initially when logged in as the root
user?
Comment 10 Leslie Brooks 2008-05-31 10:09:10 EDT
I doubt it, but I can't categorically deny it.  My usual procedure is to login
as me and then su to root if I need to do some terminal stuff with full rights,
so it is very, very rare that I would login as root at the login screen. 
However, it isn't impossible, and it is somewhat more possible in the context of
configuring a new system.
Comment 11 Richard Hughes 2008-06-03 09:37:51 EDT
Leslie, can you reproduce this? I can't - my HP printer installed just fine when
logged in non-root. Could you verify it works by manually removing the packages,
and replugging the printer. Thanks.
Comment 12 Leslie Brooks 2008-06-03 10:19:33 EDT
As noted above, I wasn't able to reproduce it; it should be marked
'Intermittent' or 'Rare'.

I will have an opportunity to try it again soon and will add more notes if it
happens again.
Comment 13 Richard Hughes 2008-06-03 10:49:33 EDT
Okay, if you can reproduce then please re-open, thanks.

Note You need to log in before you can comment on or make changes to this bug.