Bug 445966 - Netfs needs to come after NetworkManager
Netfs needs to come after NetworkManager
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
9
i686 Linux
low Severity low
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-10 13:35 EDT by G.Wolfe Woodbury
Modified: 2008-05-21 10:54 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-20 16:54:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description G.Wolfe Woodbury 2008-05-10 13:35:47 EDT
Description of problem:
  during boot, netfs runs before network manager, leaving the NFS mounted file
systems unmounted when the NM finally comes along.

Version-Release number of selected component (if applicable):


How reproducible:
  always


Steps to Reproduce:
1. add an NFS mounted filesystem to fstab
2. reboot
3.
  
Actual results:
  filesystem is not mounted after system comes up

Expected results:
  NFS mounted directories should be available after booting without having to
specifically mount them.

Additional info:

  this may belong in initscripts or something
Comment 1 Bug Zapper 2008-05-14 06:58:11 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 W. Michael Petullo 2008-05-19 19:39:59 EDT
The autofs daemon has the same problem. Autofs is started with a priority of 28, well before 
NetworkManager. If a system's autofs maps are provided by LDAP, then autofs will not read them because 
the network is not available yet.
Comment 3 Dan Williams 2008-05-19 20:34:00 EDT
NM starts at 27 on a stock F9 install.  Make sure you:

chkconfig haldaemon resetpriorities
chkconfig NetworkManager resetpriorities

does NM then still come after #27?
Comment 4 W. Michael Petullo 2008-05-20 12:47:39 EDT
Running the chkconfig commands from comment #3 reassigned new priorities to NetworkManager (27) 
and hald (26). However, the network is still not up when autofs runs. I suspect that the NetworkManager 
daemon is running in the background but does not get the network up in time for autofs (priority 28).

The laptop in question received a fresh Fedora 9 Preview install and this resulted in NetworkManager 
receiving a priority of 99. Was this changed between the preview and final release? Or is there a bug in the 
installer or rpm postinstall scripts?

Note that I don't know if this fixes the original issue with netfs, as I don't use that feature.
Comment 5 Dan Williams 2008-05-20 15:30:07 EDT
Add:

NETWORKWAIT=yes

to /etc/sysconfig/network to block startup until the network comes up or until
10 seconds have passed.  If 10s is not enough, set:

LINKDELAY=30

or however many seconds you'd like.
Comment 6 G.Wolfe Woodbury 2008-05-20 16:10:33 EDT
For me this is now a moot question,
I don't like Network manager and have no wireless devices on the systems concerned

I've turned off NetworkManager and reverted to the old simple network method

Comment 7 Dan Williams 2008-05-20 16:54:40 EDT
Ok, thanks for the report.  Resolution for this is to ensure that, if updating a
system from before F9, that the priorities are correct (NM and dbus reset
priorites in their %post, not sure about HAL but if it doesn't that's a bug). 
And if a service requires network to be up by the time it's running, adding
NETWORKWAIT and LINKDELAY as necessary.
Comment 8 W. Michael Petullo 2008-05-20 20:48:38 EDT
After I performed the steps I mentioned in comment #4, NETWORKWAIT=yes fixed my problem.

As I mentioned before, I don't have any experience with netfs.

I am planning on doing a fresh Fedora 9 install on my home server. This will allow me to retest whether NetworkManager and hald have their priorities set properly after installing. As I mentioned, my laptop ended up with incorrect priorities.
Comment 9 Dan Williams 2008-05-21 10:54:24 EDT
Michael; great.  Looking forward to hearing what your fresh install does.  Both
the LiveCD and full netinstalls I've done have placed dbus at 22, hal at 26, and
NM at 27.

Note You need to log in before you can comment on or make changes to this bug.