Bug 445967 - Fedora-packager needs to require curl
Fedora-packager needs to require curl
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: fedora-packager (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Dennis Gilmore
Fedora Extras Quality Assurance
:
: 448134 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-10 13:41 EDT by Konstantin Ryabitsev
Modified: 2009-03-19 12:23 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-19 12:23:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Konstantin Ryabitsev 2008-05-10 13:41:19 EDT
$ make new-sources FILES=yaz-3.0.26.tar.gz  
Checking : yaz-3.0.26.tar.gz on
https://cvs.fedoraproject.org/repo/pkgs/upload.cgi...
/bin/sh: line 5: curl: command not found
ERROR: could not check remote file status
make: *** [new-sources] Error 255

$ rpm -q fedora-packager
fedora-packager-0.3.0-1.fc9.noarch
Comment 1 Bug Zapper 2008-05-14 06:58:18 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 Chris Ricker 2008-05-18 15:36:41 EDT
Needs to require both ruby and curl

[kaboom@scratchmonkey devel]$ make new-sources FILES="rrdtool-1.3rc4.tar.gz" 
sh: ruby: command not found
sh: ruby: command not found

Checking : rrdtool-1.3rc4.tar.gz on
https://cvs.fedoraproject.org/repo/pkgs/upload.cgi...
/bin/sh: line 5: curl: command not found
ERROR: could not check remote file status
make: *** [new-sources] Error 255
[kaboom@scratchmonkey devel]$
Comment 3 Andreas Thienemann 2008-09-07 08:47:58 EDT
*** Bug 448134 has been marked as a duplicate of this bug. ***
Comment 4 Dennis Gilmore 2009-03-19 12:23:07 EDT
Ruby is not required at all,  curl has been added with fedora-packager-0.3.3-1.fc9

ruby is used at build time in your spec file.

Note You need to log in before you can comment on or make changes to this bug.