Bug 445982 - nxagent segfault with Gnome as Desktop
nxagent segfault with Gnome as Desktop
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: nx (Show other bugs)
8
All Linux
low Severity medium
: ---
: ---
Assigned To: Axel Thimm
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-10 20:46 EDT by JM
Modified: 2008-09-16 19:23 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-16 19:20:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description JM 2008-05-10 20:46:52 EDT
I have the problem that the nx version 3.1.0-25.1.fc8 doesn't work with Gnome as Desktop, on the 
server the nxagent fails with an segfault:

May 11 02:10:30 foo kernel: nxagent[7717]: segfault at 00000010 eip 0806beac esp bf960c70 error 4

When I use KDE as Desktop I can login without problems but the old nx version 2.1.0-22.fc7 works for 
Gnome and KDE (same system, just switched the RPMs). 

I have the problem on 3 systems with Fedora 8 and nx 3.1.0-25.1.fc8 (32bit and 64bit).

This are the nx RPMs which create the segfault with Gnome

nx-3.1.0-25.1.fc8
freenx-server-0.7.2-8.fc8

and this are the working RPMs:

nx-2.1.0-22.fc7
freenx-server-0.7.2-8.fc8

I tried also this hint http://www.ultranetsolutions.com/Fedora-8-NoMachine-NX-and-Gnome-Issues-
RESOLVED.html but it doesn't work for me, the nxagent creates still a segfault.
Comment 1 Axel Thimm 2008-08-26 14:51:12 EDT
There are new updates for nx/freenx-server for F9 and F8:

https://admin.fedoraproject.org/updates/nx-3.2.0-30.fc9,freenx-server-0.7.3-11.fc9
https://admin.fedoraproject.org/updates/nx-3.2.0-30.fc8,freenx-server-0.7.3-11.fc8

The packages are schedules to be released in updates-testing first, but you can already pull them manually from the URLs above.

Please check whether the reported issue still applies to these packages. Thanks!
Comment 2 JM 2008-08-26 23:04:48 EDT
It looks like that the bug is gone with the new versions, but now I run into a new bug it's the missing /tmp/.X11-unix directory (https://bugzilla.redhat.com/show_bug.cgi?id=437655 or http://article.gmane.org/gmane.network.freenx.general/6015). I create now the directory (if it is missing) on startup but maybe you can include a initscript which creates the directory if it is missing.
Comment 3 Fedora Update System 2008-09-10 02:40:36 EDT
freenx-server-0.7.3-11.fc8, nx-3.2.0-30.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update freenx-server nx'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F8/FEDORA-2008-7600
Comment 4 Fedora Update System 2008-09-10 02:43:43 EDT
freenx-server-0.7.3-11.fc9, nx-3.2.0-30.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update freenx-server nx'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-7522
Comment 5 Fedora Update System 2008-09-16 19:20:01 EDT
freenx-server-0.7.3-11.fc9, nx-3.2.0-30.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 6 Fedora Update System 2008-09-16 19:23:15 EDT
freenx-server-0.7.3-11.fc8, nx-3.2.0-30.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.