Bug 445984 - If a mirror is bad Anaconda doesn't prompt user to try another
If a mirror is bad Anaconda doesn't prompt user to try another
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Chris Lumens
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-10 20:48 EDT by Shawn Starr
Modified: 2008-07-03 19:15 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-03 19:15:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Shawn Starr 2008-05-10 20:48:10 EDT
Description of problem:

When installing Fedora 9 (Rawhide) over the net, if you use a mirror thats
missing an RPM (in this case gnome-backgrounds was missing). The 'Starting
install process' screen hangs indefinitely, Anaconda doesn't notify you there's
any missing RPMs other than in the console vt output.


Version-Release number of selected component (if applicable):
11.0.4.82-1

How reproducible:
Depends on mirror if it is fully sync'd or not.

Steps to Reproduce:
1. Pop in CD, do select URI put in a mirror
2. Finish partitioning, package selection, click next
3. Wait...
  
Actual results:

Anaconda doesn't see to timeout or prompt for another mirror to try.

Expected results:

Anaconda should alert user the mirror they used is 'bad' and that they should
pick another/type another mirror and retry fetching packages/install components.


Additional info:
The mirror used was fedora.mirror.iweb.ca using development/i386/os

This sort of failure doesn't make for a good user experience when installing
Fedora. Hence medium priority/severity level.
Comment 1 Chris Lumens 2008-05-12 11:22:26 EDT
Can you attach /tmp/anaconda.log from when it's sitting there hung to this bug
report?  Thanks.
Comment 2 Bug Zapper 2008-05-14 06:59:04 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 Shawn Starr 2008-07-03 19:15:24 EDT
Closing. I can't reproduce. Assuming I ever see this again Anaconda will look
different anyway :-)


Note You need to log in before you can comment on or make changes to this bug.