This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 445985 - Anaconda finds a multipath controller where none exists
Anaconda finds a multipath controller where none exists
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: python-pyblock (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-10 20:53 EDT by Leslie Brooks
Modified: 2009-07-14 12:09 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-14 12:09:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Fdisk taken under the installed Beta (3.35 KB, text/plain)
2008-05-10 20:53 EDT, Leslie Brooks
no flags Details
Output from lshal + /tmp/syslog (18.35 KB, application/x-zip-compressed)
2008-05-13 21:15 EDT, Leslie Brooks
no flags Details

  None (edit)
Description Leslie Brooks 2008-05-10 20:53:53 EDT
Description of problem:  I have the Fedora 9 Beta installed and am attempting to
install the Preview.  However, the preview doesn't see all of my hard drives
during the installation.  I have seven drives:
 - (2) 14GB drives, mirrored in the BIOS; I have F9 Beta installed on these
 - (2) SATA drives connected to the motherboard
 - (2) IDE drives connected to a Maxtor PCI card
 - (1) IDE drive connected to a Promise PCI card
 - the motherboard is an ASUS K8N-E Deluxe with the latest (but not Beta) firmware

All of the IDE drives are bus masters on their own cables and are identified by
the BIOS at boot time.  I installed Beta with just the two mirrored drives, so I
don't know what it sees at install time, but when I run the Beta (and run fdisk)
all seven drives are identified.  (See attachment).

When I boot the Preview DVD and get to the drive configuration page I select
manual configuration.  Preview sees MAPPER (the mirror), SDE (SATA), SDF (IDE)
and SDG (SATA).  It appears to be missing the two drives on the Maxtor
controller, and very oddly it skips SDC and SDD.

The Ubuntu 8.04 installer sees all seven drives (but doesn't show that SDA and
SDB are mirrored).  It identifies them as SDA-SDF plus /dev/hda and shows the
correct size for each.


Version-Release number of selected component (if applicable):
 Anaconda 11.4.0.73

How reproducible:
 I tried it twice and got the same results both times.

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:
 I would expect it to see all of the drives.

Additional info:
Comment 1 Leslie Brooks 2008-05-10 20:53:53 EDT
Created attachment 305044 [details]
Fdisk taken under the installed Beta
Comment 2 Leslie Brooks 2008-05-11 14:20:23 EDT
I tried moving the IDE interface card to a different PCI slot, but that didn't
help.  However, I was able to get the chip IDs.  The two cards have:
 - Promise PDC2067 (HDs are recognized at install time)
 - SILO68OACL144 (HDs are recognized after installation, but not at install time)
Comment 3 Jeremy Katz 2008-05-12 09:53:33 EDT
Can you get the output of /tmp/syslog and lshal when the installer is running?
Comment 4 Leslie Brooks 2008-05-12 19:01:05 EDT
I'm sure I can if you give me instructions.  I assume I need to break into the
installer and copy those files to a Flash drive?  However, I don't know how to
get to a shell from the installer.
Comment 5 Chris Lumens 2008-05-13 10:11:46 EDT
ctrl-alt-f2 will drop you to a shell once you're in the graphical installer.
Comment 6 Leslie Brooks 2008-05-13 21:15:20 EDT
Created attachment 305314 [details]
Output from lshal + /tmp/syslog
Comment 7 Leslie Brooks 2008-05-13 21:16:37 EDT
I have attached the output from lshal and /tmp/syslog.
Comment 8 Bug Zapper 2008-05-14 06:59:10 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 9 Leslie Brooks 2008-05-21 21:11:21 EDT
The problem appears NOT to be that the installer doesn't support one of my drive
interfaces, but rather that it doesn't like something about the drive itself. 
It shows a mapped drive of 200GB (the size of my drives); I don't understand why
it does that.  However, seeing that gave me the idea to format the drives and
see if that fixed the problem.  I booted from a Fedora 9 Live USB drive, ran
mkfs on each drive in turn, and on two of them (sdc1 and sde1) it said 'This
drive appears to be in use' and refused to format it.  All of the others
formatted just fine.  I removed what I believed to be sdc1 from the system;
after I did that I was able to format all of the remaining drives.  I will try
installing again and see if it now sees four 200GB drives rather than three.

Could the installer think that I have mirrored two of the drives?  That would
give me one 200GB 'mapper' drive, and only three remaining 200GB drives. 
However, these drives have never been mirrored.  Three of them were once a
single LV, but never part of an mdadm mirror.
Comment 10 Leslie Brooks 2008-05-21 21:22:45 EDT
Yes, with sdc removed and the other drives (including sde1 which was 'in use'
yesterday) reformatted, the installer sees four 200GB drives as it should.  The
next step is to reinstall sdc and see if the installer then sees all five drives.

If you need more information please let me know ASAP; I don't want my attempts
to diagnose and fix the problem to destroy the evidence you need.
Comment 11 Leslie Brooks 2008-05-21 21:33:56 EDT
With sdc1 reinstalled I get no joy - four drives (the two SATA drives plus one
of the 190780 MB IDE drives, plus a 190780 MB device-mapper drive.

What other tests would you like me to run?
Comment 12 Leslie Brooks 2008-05-26 09:05:49 EDT
I finally figured out what is going wrong and how to work around it, although I
still have no clue why.  Anaconda thinks two of my drives are a single drive,
reachable via a multipath controller.  My humble server has never had a
multipath controller!  What is even more puzzling is that the two drives
involved are a SATA and an IDE drive, and are not even the same size.

The workaround of course is to add 'nompath' as a kernel option.  (Now as soon
as the blasted repository is fixed so I no longer get 'Unable to read group
information..." I think I can actually install!)

If you need more diagnostic information to determine the root cause please let
me know.
Comment 13 Bug Zapper 2009-06-09 20:43:24 EDT
This message is a reminder that Fedora 9 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 9.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '9'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 9's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 9 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 14 Bug Zapper 2009-07-14 12:09:39 EDT
Fedora 9 changed to end-of-life (EOL) status on 2009-07-10. Fedora 9 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.