Bug 445988 - No search results getting returned
No search results getting returned
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: linuxdcpp (Show other bugs)
8
i686 Linux
low Severity low
: ---
: ---
Assigned To: Marcin Garski
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-11 02:26 EDT by JP Viljoen
Modified: 2009-01-09 01:29 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-09 01:29:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description JP Viljoen 2008-05-11 02:26:42 EDT
Description of problem: Searching for something in LinuxDCPP when connected to a
server does not return results.

Version-Release number of selected component (if applicable): LinuxDCPP 1.0.1,
core 0.698. Server = Open DC Hub (0.7.15).

How reproducible: Always.


Steps to Reproduce:
1. Open LinuxDCPP
2. Connect to server
3. Search for anything which is known to be on DC shares
  
Actual results: No results returned to search query.


Expected results: Return accurate results.


Additional info: Have verified it is not a LinuxDCPP issue but a Fedora-specific
issue by connecting to the same hub from an Ubuntu (8.04) installation, same hub
and same version of LinuxDCPP
Comment 1 Marcin Garski 2008-05-11 13:42:59 EDT
Please remove your current configuration, then try to search for something and
see if still no results are returned.
Comment 2 JP Viljoen 2008-05-13 09:25:23 EDT
Did as requested, still no search results at all. Just the little text label at
the bottom side of the search window going "Searching for $query", and I could
see that some data got uploaded and downloaded, which I presume was the traffic
for the search. I searched for "ubuntu", 886bytes went up, 2.86KB came down
Comment 3 Marcin Garski 2008-05-13 09:59:44 EDT
It's strange that you see a "$query" text. It should be the phrase that you have
entered. Do you have a clean Fedora 8 installation, or you have made upgrade
from previous version? Have you changed something on search tab in linuxdcpp
(like searching on hubs that you have op on them)? Do you get any result if you
execute this command: ldd /usr/bin/linuxdcpp | grep "not found"
Comment 4 JP Viljoen 2008-05-14 16:51:20 EDT
Sorry, when I typed "$query", I meant it as saying that that which is displayed
is whichever query I entered. I think it is a clean Fedora 8 install (I'm
honestly not sure, can't remember, and if I had any old packages still in my
cleanup scripts and things will have taken care of them). No missing libraries
getting returned by the ldd-grep either. All settings in linuxdcpp are
completely vanilla, clean configure with just nickname configured and then
directly connected to the server, not even the server set up as a favourite. I
could attempt (later this week) creating a scratch install of F8, and then also
one of F7->F8 and try to find if this is the issue/source?
Comment 5 Marcin Garski 2008-05-19 18:07:52 EDT
Do you have any active firewall on Fedora that could block DC packets?

I would appreciate if you could do a clean F8 install.
Comment 6 Bug Zapper 2008-11-26 05:40:39 EST
This message is a reminder that Fedora 8 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 8.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '8'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 8's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 8 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 7 Bug Zapper 2009-01-09 01:29:39 EST
Fedora 8 changed to end-of-life (EOL) status on 2009-01-07. Fedora 8 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.