Bug 445989 - package contains empty desktop file
package contains empty desktop file
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kdebase (Show other bugs)
8
All Linux
low Severity medium
: ---
: ---
Assigned To: Kevin Kofler
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-11 04:50 EDT by Christian Krause
Modified: 2010-12-07 13:41 EST (History)
9 users (show)

See Also:
Fixed In Version: 4.0.4-1.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-21 07:00:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christian Krause 2008-05-11 04:50:53 EDT
Description of problem:
the latest update of kdebase4 contains a desktop file which is empty:
----------------------------------
rpm -qlv kdebase4 |grep konquerorsu
-rw-r--r--    1 root    root                0 Apr 22 21:44
/usr/share/applications/kde4/konquerorsu.desktop
----------------------------------


This results in errors when updating the desktop-database (which happens quite
often during updating):
----------------------------------
/usr/bin/update-desktop-database /usr/share/applications
Could not parse file '/usr/share/applications/kde4/konquerorsu.desktop': File is
empty
----------------------------------

Version-Release number of selected component (if applicable):
kdebase4-4.0.3-9.fc8
Comment 1 Kevin Kofler 2008-05-11 05:00:11 EDT
Confirmed. The offending file is still present in kdebase4-4.0.4-1.fc8 in 
updates-testing.
Comment 2 Kevin Kofler 2008-05-11 05:06:00 EDT
The problem is this specfile 

# konquerorsu only show in KDE
echo OnlyShowIn=KDE; 
>> %{buildroot}%{_kde4_datadir}/applications/kde4/konquerorsu.desktop

which should only be there for F9+, and which is also broken there because the 
semicolon is not quoted, so this appends absolutely nothing (the output of the 
empty command) to konquerorsu.desktop.
Comment 3 Kevin Kofler 2008-05-11 05:18:26 EDT
Fixed in 4.0.4-2.fc9 and 4.0.72-2.fc10.
Comment 4 Kevin Kofler 2008-05-11 05:19:10 EDT
Uh, actually that's the other one (the unquoted semicolon), this one is fixed 
in 4.0.4-2.fc7 and 4.0.4-2.fc8 of course. :-)
Comment 5 Fedora Update System 2008-05-14 18:16:16 EDT
kdebase4-4.0.4-2.fc8, kdepimlibs-4.0.4-1.fc8, kdelibs4-4.0.4-2.fc8, kdebase-runtime-4.0.4-1.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update kdebase4 kdepimlibs kdelibs4 kdebase-runtime'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F8/FEDORA-2008-3475
Comment 6 Fedora Update System 2008-05-21 07:00:07 EDT
kdebase-runtime-4.0.4-1.fc8, kdelibs4-4.0.4-4.fc8, kdepimlibs-4.0.4-1.fc8, kdebase4-4.0.4-2.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.