Bug 445992 - canot start cowbell
canot start cowbell
Status: CLOSED DUPLICATE of bug 442338
Product: Fedora
Classification: Fedora
Component: cowbell (Show other bugs)
9
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Sindre Pedersen Bjørdal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-11 06:36 EDT by Sjoerd Mullender
Modified: 2008-08-03 09:42 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-03 09:42:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Modify the sed command to expand the @libdir@ in cowbell.in (417 bytes, patch)
2008-05-12 16:02 EDT, Kyle VanderBeek
no flags Details | Diff

  None (edit)
Description Sjoerd Mullender 2008-05-11 06:36:31 EDT
Description of problem:
$ cowbell
Cannot open assembly @libdir@/cowbell/cowbell.exe.


Need I say more?


Version-Release number of selected component (if applicable):
cowbell-0.2.7.1-10.fc8.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Run cowbell at the command prompt.
2.
3.
  
Actual results:
Error message: Cannot open assembly @libdir@/cowbell/cowbell.exe.
and program exits.

Expected results:
No error message and program starts.

Additional info:
Comment 1 Kyle VanderBeek 2008-05-12 16:02:18 EDT
Created attachment 305174 [details]
Modify the sed command to expand the @libdir@ in cowbell.in

Makefile.in doesn't expand all the variables in cowbell.in, leaving @libdir@
untranslated.

Add:
    Patch1: cowbell-libdir-expand.patch
and
    %patch1 -p1
To the spec file and it works.
Comment 2 Sindre Pedersen Bjørdal 2008-05-29 08:20:52 EDT
Above patch works, but due to changes in Amazon api, fetching any information no
longer works on the 0.2 branch. Using 0.3 pre-release from svn instead, as this
provides expected functionality via musicbrainz. Updated package, including
above patch, tested by me to work on both i386 and x86_64, pending -testing
inclusion for F-9 now: See
https://admin.fedoraproject.org/updates/F9/pending/cowbell-0.3-0.svn34.4.2.fc9
Comment 3 Sjoerd Mullender 2008-06-16 16:58:04 EDT
$ rpm -q cowbell
cowbell-0.3-0.svn34.4.2.fc9.x86_64
$ cowbell
Cannot open assembly /usr/lib/cowbell/cowbell.exe.

This is on an x86_64 system with the latest version of cowbell.  The problem is
that in /usr/bin/cowbell, libdir is defined as "/usr/lib/cowbell" instead of
"/usr/lib64/cowbell".
Comment 4 Sjoerd Mullender 2008-06-17 12:11:14 EDT
As a follow up on comment #3, after I changed the definition of libdir in
/usr/bin/cowbell to /usr/lib64/cowbell, I get this error:
$ cowbell

** (cowbell:23695): WARNING **: The following assembly referenced from
/usr/lib64/cowbell/Cowbell.Base.dll could not be loaded:
     Assembly:   taglib-sharp    (assemblyref_index=3)
     Version:    2.0.3.0
     Public Key: db62eba44689b5b0
The assembly was not found in the Global Assembly Cache, a path listed in the
MONO_PATH environment variable, or in the location of the executing assembly
(/usr/lib64/cowbell).


** (cowbell:23695): WARNING **: Could not load file or assembly 'taglib-sharp,
Version=2.0.3.0, Culture=neutral, PublicKeyToken=db62eba44689b5b0' or one of its
dependencies.

Unhandled Exception: System.Reflection.ReflectionTypeLoadException: The classes
in the module cannot be loaded.
  at (wrapper managed-to-native) System.Reflection.Assembly:GetTypes (bool)
  at System.Reflection.Assembly.GetTypes () [0x00000] in
/builddir/build/BUILD/mono-1.9.1/mcs/class/corlib/System.Reflection/Assembly.cs:336 
  at Cowbell.Base.MetadataProxyService.Load () [0x00000] 
  at Cowbell.Base.ServiceManager.RegisterService (IService service) [0x00000] 
  at Cowbell.Gui.MainWindow.Main (System.String[] args) [0x00000] 
Comment 5 Sjoerd Mullender 2008-06-17 12:13:07 EDT
I changed the Fedora version to 9 since that's what I'm using.
Comment 6 Sindre Pedersen Bjørdal 2008-08-03 09:42:43 EDT

*** This bug has been marked as a duplicate of bug 442338 ***

Note You need to log in before you can comment on or make changes to this bug.