Bug 446005 - OOo Impress dies on x86
OOo Impress dies on x86
Status: CLOSED DUPLICATE of bug 447912
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
9
i386 Linux
high Severity high
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
:
: 436518 447374 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-11 15:31 EDT by Paul F. Johnson
Modified: 2008-08-01 05:44 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-02 17:32:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
replacement /usr/lib/openoffice.org/program/libemboleobj.so (175.08 KB, application/octet-stream)
2008-05-12 11:43 EDT, Caolan McNamara
no flags Details

  None (edit)
Description Paul F. Johnson 2008-05-11 15:31:39 EDT
Description of problem:
OOo Impress randomly dies on x86

Version-Release number of selected component (if applicable):
2.4.0.12-8

How reproducible:
100%

Steps to Reproduce:
1. Start to create a presentation
2. Wait for a bit
3.
  
Actual results:
(I)    x.org loaded video driver of...
(II) Loading /usr/lib/xorg/modules/drivers//intel_drv.so
(II) Loading /usr/lib/xorg/modules/drivers//intel_master_drv.so
(==) Depth 24 pixmap format is 32 bpp
(III)  Desktop is: GNOME
(IV)   openoffice.org-kde version is: package openoffice.org-kde is not installed
(V)    libgcj version is: libgcj-4.3.0-8-i386
(IV)   kernel is: Linux 2.6.25-14.fc9.i686 #1 SMP Thu May 1 06:28:41 EDT 2008
i686 i686 i386
(VII)  OpenOffice.org core rpm version is: openoffice.org-core-2.4.0-12.8.fc9-i386
(VIII) accessibility is: false
(VIV)  fedora release is: Fedora release 9 (Sulphur)
(VV)   LANG is: en_GB.UTF-8
...start free space details ...
Filesystem           1K-blocks      Used Available Use% Mounted on
/dev/mapper/VolGroup00-LogVol00
                     149186740  14696392 126789868  11% /
/dev/mapper/VolGroup00-LogVol00
                     149186740  14696392 126789868  11% /
...end free space details ...
...start sestatus details ...
SELinux status:                 enabled
SELinuxfs mount:                /selinux
Current mode:                   permissive
Mode from config file:          permissive
Policy version:                 22
Policy from config file:        targeted
...end sestatus details ...
...start stackreport details ...
0x79fd3e8: 0x1c4c7c: /usr/lib/openoffice.org/program/libuno_sal.so.3 + 0x253e8
0x79fdd23: 0x1c4c7c: /usr/lib/openoffice.org/program/libuno_sal.so.3 + 0x25d23
0x110400: 0x0:  + 0x400 (__kernel_sigreturn + 0x0)
0x7a0ccc0: 0x1c4c7c: /usr/lib/openoffice.org/program/libuno_sal.so.3 + 0x34cc0
(rtl_uString_newFromAscii + 0x20)
0x1bebeb2: 0x2a3bc: /usr/lib/openoffice.org/program/libemboleobj.so + 0xeeb2
0x1bee3aa: 0x2a3bc: /usr/lib/openoffice.org/program/libemboleobj.so + 0x113aa
(OleEmbeddedObject::TryToRetrieveCachedVisualRepresentation_Impl(com::sun::star::uno::Reference<com::sun::star::io::XStream>
const&, unsigned char) + 0x1b8)
0x1bf02b5: 0x2a3bc: /usr/lib/openoffice.org/program/libemboleobj.so + 0x132b5
(OleEmbeddedObject::StoreToLocation_Impl(com::sun::star::uno::Reference<com::sun::star::embed::XStorage>
const&, rtl::OUString const&,
com::sun::star::uno::Sequence<com::sun::star::beans::PropertyValue> const&,
com::sun::star::uno::Sequence<com::sun::star::beans::PropertyValue> const&,
unsigned char) + 0x521)
0x1bf0513: 0x2a3bc: /usr/lib/openoffice.org/program/libemboleobj.so + 0x13513
(OleEmbeddedObject::storeAsEntry(com::sun::star::uno::Reference<com::sun::star::embed::XStorage>
const&, rtl::OUString const&,
com::sun::star::uno::Sequence<com::sun::star::beans::PropertyValue> const&,
com::sun::star::uno::Sequence<com::sun::star::beans::PropertyValue> const&) + 0x7f)
0x31fe363: 0x37a7e0: /usr/lib/openoffice.org/program/libsfx680li.so + 0x12e363
(SfxObjectShell::SaveAsChildren(SfxMedium&) + 0x4a9)
0x31fe631: 0x37a7e0: /usr/lib/openoffice.org/program/libsfx680li.so + 0x12e631
(SfxObjectShell::SaveAs(SfxMedium&) + 0x1d)
0x471ca7b: 0x52641c: /usr/lib/openoffice.org/program/libsd680li.so + 0x186a7b
(sd::DrawDocShell::SaveAs(SfxMedium&) + 0x65)
0x31fed1d: 0x37a7e0: /usr/lib/openoffice.org/program/libsfx680li.so + 0x12ed1d
(SfxObjectShell::SaveAsOwnFormat(SfxMedium&) + 0x75)
0x471c1b7: 0x52641c: /usr/lib/openoffice.org/program/libsd680li.so + 0x1861b7
(sd::DrawDocShell::SaveAsOwnFormat(SfxMedium&) + 0x24b)
0x32000c3: 0x37a7e0: /usr/lib/openoffice.org/program/libsfx680li.so + 0x1300c3
0x3201893: 0x37a7e0: /usr/lib/openoffice.org/program/libsfx680li.so + 0x131893
0x3201f1d: 0x37a7e0: /usr/lib/openoffice.org/program/libsfx680li.so + 0x131f1d
0x32079e9: 0x37a7e0: /usr/lib/openoffice.org/program/libsfx680li.so + 0x1379e9
0x3235065: 0x37a7e0: /usr/lib/openoffice.org/program/libsfx680li.so + 0x165065
0x323b1f9: 0x37a7e0: /usr/lib/openoffice.org/program/libsfx680li.so + 0x16b1f9
(SfxBaseModel::storeToURL(rtl::OUString const&,
com::sun::star::uno::Sequence<com::sun::star::beans::PropertyValue> const&) + 0xaf)
0x358b451: 0x25488c: /usr/lib/openoffice.org/program/libfwk680li.so + 0x137451
0x358bac7: 0x25488c: /usr/lib/openoffice.org/program/libfwk680li.so + 0x137ac7
0x358bf84: 0x25488c: /usr/lib/openoffice.org/program/libfwk680li.so + 0x137f84
0x358c0c9: 0x25488c: /usr/lib/openoffice.org/program/libfwk680li.so + 0x1380c9
0x7c418a4: 0x37e324: /usr/lib/openoffice.org/program/libvcl680li.so + 0x9c8a4
(Timer::Timeout() + 0x18)
0x7c41da7: 0x37e324: /usr/lib/openoffice.org/program/libvcl680li.so + 0x9cda7
(Timer::ImplTimerCallbackProc() + 0x7b)
0x20d9c2: 0x7859c: /usr/lib/openoffice.org/program/libvclplug_gen680li.so +
0x429c2 (X11SalData::Timeout() const + 0x2a)
0x122be9: 0x4b950: /usr/lib/openoffice.org/program/libvclplug_gtk680li.so + 0x11be9
0x6bc7c6: 0xe0108: /lib/libglib-2.0.so.0 + 0x377c6
0x6bc098: 0xe0108: /lib/libglib-2.0.so.0 + 0x37098 (g_main_context_dispatch + 0x1e8)
0x6bf743: 0xe0108: /lib/libglib-2.0.so.0 + 0x3a743
0x6bf901: 0xe0108: /lib/libglib-2.0.so.0 + 0x3a901 (g_main_context_iteration + 0x71)
0x122827: 0x4b950: /usr/lib/openoffice.org/program/libvclplug_gtk680li.so + 0x11827
0x2168b9: 0x7859c: /usr/lib/openoffice.org/program/libvclplug_gen680li.so +
0x4b8b9 (X11SalInstance::Yield(bool, bool) + 0x2f)
0x7c3dcb9: 0x37e324: /usr/lib/openoffice.org/program/libvcl680li.so + 0x98cb9
(Application::Yield(bool) + 0x57)
0x7c3dd07: 0x37e324: /usr/lib/openoffice.org/program/libvcl680li.so + 0x98d07
(Application::Execute() + 0x2b)
0x36dd933: 0x77340: /usr/lib/openoffice.org/program/libsoffice.so + 0x2f933
(desktop::Desktop::Main() + 0x1a0b)
0x7c412c2: 0x37e324: /usr/lib/openoffice.org/program/libvcl680li.so + 0x9c2c2
0x7c4145e: 0x37e324: /usr/lib/openoffice.org/program/libvcl680li.so + 0x9c45e
(SVMain() + 0x2c)
0x36d1f01: 0x77340: /usr/lib/openoffice.org/program/libsoffice.so + 0x23f01
(main + 0xe5)
0x35f5d6: 0x164d7c: /lib/libc.so.6 + 0x165d6 (__libc_start_main + 0xe6)
0x80484f1: 0x6dc: /usr/lib/openoffice.org/program/simpress.bin + 0x4f1 (main + 0x51)
...end stackreport details ...
...start sample ldd details ...
	linux-gate.so.1 =>  (0x00110000)
	libgtk-x11-2.0.so.0 => /usr/lib/libgtk-x11-2.0.so.0 (0x00347000)
	libgdk-x11-2.0.so.0 => /usr/lib/libgdk-x11-2.0.so.0 (0x00162000)
	libatk-1.0.so.0 => /usr/lib/libatk-1.0.so.0 (0x001f8000)
	libgdk_pixbuf-2.0.so.0 => /usr/lib/libgdk_pixbuf-2.0.so.0 (0x00215000)
	libpangocairo-1.0.so.0 => /usr/lib/libpangocairo-1.0.so.0 (0x00232000)
	libpango-1.0.so.0 => /usr/lib/libpango-1.0.so.0 (0x0023c000)
	libcairo.so.2 => /usr/lib/libcairo.so.2 (0x0027f000)
	libgmodule-2.0.so.0 => /lib/libgmodule-2.0.so.0 (0x002ee000)
	libdl.so.2 => /lib/libdl.so.2 (0x002f2000)
	libgthread-2.0.so.0 => /lib/libgthread-2.0.so.0 (0x002f7000)
	librt.so.1 => /lib/librt.so.1 (0x002fc000)
	libdbus-glib-1.so.2 => /usr/lib/libdbus-glib-1.so.2 (0x00306000)
	libdbus-1.so.3 => /lib/libdbus-1.so.3 (0x00747000)
	libgobject-2.0.so.0 => /lib/libgobject-2.0.so.0 (0x00788000)
	libglib-2.0.so.0 => /lib/libglib-2.0.so.0 (0x007c8000)
	libvclplug_gen680li.so =>
/usr/lib/openoffice.org/program/libvclplug_gen680li.so (0x008a9000)
	libvcl680li.so => /usr/lib/openoffice.org/program/libvcl680li.so (0xb7be8000)
	libpsp680li.so => /usr/lib/openoffice.org/program/libpsp680li.so (0xb7b07000)
	libsot680li.so => /usr/lib/openoffice.org/program/libsot680li.so (0xb7aa9000)
	libutl680li.so => /usr/lib/openoffice.org/program/libutl680li.so (0xb7a23000)
	libtl680li.so => /usr/lib/openoffice.org/program/libtl680li.so (0xb7980000)
	libcomphelp4gcc3.so => /usr/lib/openoffice.org/program/libcomphelp4gcc3.so
(0xb7882000)
	libucbhelper4gcc3.so => /usr/lib/openoffice.org/program/libucbhelper4gcc3.so
(0xb7817000)
	libuno_cppuhelpergcc3.so.3 =>
/usr/lib/openoffice.org/program/libuno_cppuhelpergcc3.so.3 (0xb7782000)
	libuno_cppu.so.3 => /usr/lib/openoffice.org/program/libuno_cppu.so.3 (0xb7754000)
	libvos3gcc3.so => /usr/lib/openoffice.org/program/libvos3gcc3.so (0xb772f000)
	libuno_sal.so.3 => /usr/lib/openoffice.org/program/libuno_sal.so.3 (0xb7563000)
	libX11.so.6 => /usr/lib/libX11.so.6 (0xb7462000)
	libXext.so.6 => /usr/lib/libXext.so.6 (0xb7452000)
	libpthread.so.0 => /lib/libpthread.so.0 (0xb7439000)
	libstlport_gcc.so => /usr/lib/openoffice.org/program/libstlport_gcc.so (0xb736e000)
	libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0xb727c000)
	libm.so.6 => /lib/libm.so.6 (0xb7252000)
	libgcc_s.so.1 => /lib/libgcc_s.so.1 (0xb7244000)
	libc.so.6 => /lib/libc.so.6 (0xb70db000)
	libXcomposite.so.1 => /usr/lib/libXcomposite.so.1 (0x00324000)
	libXfixes.so.3 => /usr/lib/libXfixes.so.3 (0x00928000)
	libpng12.so.0 => /usr/lib/libpng12.so.0 (0xb70b4000)
	libfontconfig.so.1 => /usr/lib/libfontconfig.so.1 (0xb7084000)
	libXrender.so.1 => /usr/lib/libXrender.so.1 (0xb707b000)
	libXinerama.so.1 => /usr/lib/libXinerama.so.1 (0x0092d000)
	libXi.so.6 => /usr/lib/libXi.so.6 (0xb7072000)
	libXrandr.so.2 => /usr/lib/libXrandr.so.2 (0xb706b000)
	libXcursor.so.1 => /usr/lib/libXcursor.so.1 (0xb7060000)
	libpangoft2-1.0.so.0 => /usr/lib/libpangoft2-1.0.so.0 (0xb7036000)
	libfreetype.so.6 => /usr/lib/libfreetype.so.6 (0xb6fa7000)
	libz.so.1 => /lib/libz.so.1 (0xb6f93000)
	libpixman-1.so.0 => /usr/lib/libpixman-1.so.0 (0xb6f66000)
	libselinux.so.1 => /lib/libselinux.so.1 (0xb6f49000)
	/lib/ld-linux.so.2 (0x00329000)
	libnsl.so.1 => /lib/libnsl.so.1 (0xb6f2f000)
	libcap.so.2 => /lib/libcap.so.2 (0x00930000)
	libSM.so.6 => /usr/lib/libSM.so.6 (0xb6f26000)
	libICE.so.6 => /usr/lib/libICE.so.6 (0xb6f0c000)
	libi18nisolang1gcc3.so =>
/usr/lib/openoffice.org/program/libi18nisolang1gcc3.so (0xb6f05000)
	libbasegfx680li.so => /usr/lib/openoffice.org/program/libbasegfx680li.so
(0xb6eaf000)
	libicuuc.so.38 => /usr/lib/libicuuc.so.38 (0xb6d7b000)
	libicule.so.38 => /usr/lib/libicule.so.38 (0xb6d44000)
	libjvmaccessgcc3.so.3 => /usr/lib/openoffice.org/program/libjvmaccessgcc3.so.3
(0xb6d3d000)
	libjvmfwk.so.3 => /usr/lib/openoffice.org/program/libjvmfwk.so.3 (0xb6d21000)
	libuno_salhelpergcc3.so.3 =>
/usr/lib/openoffice.org/program/libuno_salhelpergcc3.so.3 (0xb6d1d000)
	libcrypt.so.1 => /lib/libcrypt.so.1 (0xb6ceb000)
	libxcb-xlib.so.0 => /usr/lib/libxcb-xlib.so.0 (0x00327000)
	libxcb.so.1 => /usr/lib/libxcb.so.1 (0xb6cce000)
	libXau.so.6 => /usr/lib/libXau.so.6 (0xb6ccb000)
	libexpat.so.1 => /lib/libexpat.so.1 (0xb6ca4000)
	libicudata.so.38 => /usr/lib/libicudata.so.38 (0xb61cd000)
	libxml2.so.2 => /usr/lib/libxml2.so.2 (0xb607d000)
	libXdmcp.so.6 => /usr/lib/libXdmcp.so.6 (0xb6077000)
...end sample ldd details ...


Expected results:
It should do the above!

Additional info:
Untested on x86_64
Comment 1 Paul F. Johnson 2008-05-11 17:01:59 EDT
It looks like it is an autosave problem - if I switch it off, it's more stable.
Comment 2 Caolan McNamara 2008-05-12 10:18:48 EDT
This one is the biggest pain in my ass ever, there is no reason for it, valgrind
just says "it goes wrong"

if I disable optimization for the file "it works" and valgrind goes silent
if I disable -fasynchronous-unwind-tables "it works"
but for the life of me I cannot actually capture a reason for the failure
it seems to screw up after the exception is caught. bah.
Comment 3 Paul F. Johnson 2008-05-12 10:42:08 EDT
Just checked - it is there in 2.4.0.12-7 as well (downgraded to -7 to see if it
helps).

The problem doesn't seem to hit x86_64
Comment 4 Caolan McNamara 2008-05-12 10:46:23 EDT
(gdb) warning: (Internal error: pc 0x5d58897 in read in psymtab, but not in symtab.)

and if I move part of the code into a different source file it works :-(
Something very much stinks here
Comment 5 Caolan McNamara 2008-05-12 11:43:56 EDT
Created attachment 305139 [details]
replacement /usr/lib/openoffice.org/program/libemboleobj.so

If you overwrite the original .so with this replacement does it work ?
Comment 6 Paul F. Johnson 2008-05-13 04:10:45 EDT
Yep. Still some crashes, but much more stable
Comment 7 Bug Zapper 2008-05-14 07:00:14 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 8 Caolan McNamara 2008-05-19 15:28:36 EDT
*** Bug 447374 has been marked as a duplicate of this bug. ***
Comment 9 Caolan McNamara 2008-05-21 14:02:36 EDT
*** Bug 436518 has been marked as a duplicate of this bug. ***
Comment 10 Caolan McNamara 2008-06-02 17:32:02 EDT

*** This bug has been marked as a duplicate of 447912 ***
Comment 11 lihuang 2008-08-01 05:44:23 EDT
This bug has been verified with version openoffice.org-2.4.1-17.4.fc9.i386.rpm

Note You need to log in before you can comment on or make changes to this bug.