Bug 446011 - Footnotes (for URLs) aren't generating correctly in PDF
Footnotes (for URLs) aren't generating correctly in PDF
Status: CLOSED CURRENTRELEASE
Product: Publican
Classification: Community
Component: publican (Show other bugs)
2.0
All Linux
low Severity low
: ---
: ---
Assigned To: Jeff Fearn
Michael Hideo
https://engineering.redhat.com/docbot...
: Documentation
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-11 21:13 EDT by Lana Brindley
Modified: 2013-10-23 19:07 EDT (History)
4 users (show)

See Also:
Fixed In Version: 0.34
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-11 22:15:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Lana Brindley 2008-05-11 21:13:11 EDT
Description of problem:


Version-Release number of selected component (if applicable):
publican-0.33-0.el5

How reproducible:
Every time.

Steps to Reproduce:
1. Create Book using Publican
2. Include an xref
3. Publish book to PDF
  
Actual results:
Footnote numbers doubled, and missing the footnote (containing the URL) at the
bottom of the page.

Expected results:
Footnotes are numbered sequentially and the appropriate note and URL appear at
the bottom of the page.

Additional info:
Notes on example found in
https://engineering.redhat.com/docbot/en-US/Red_Hat_Enterprise_MRG/1.0/pdf/Messaging_Installation_Guide/
On page 1 of the PDF, you refer to the "Red Hat Enterprise MRG Supported
Hardware Page" with footnote 1.  First, you've already used footnote 1 on the
previous page, and second (and probably a side effect), there is no
corresponding footnote at the bottom of the page.

On Page 4, again there's no footnote for footnote 4.
Comment 1 Lana Brindley 2008-05-11 21:14:28 EDT
Oops - reproducible "every time" for this book. Probably not every time for
*every* book.

LKB
Comment 2 Jeff Fearn 2008-05-11 22:15:47 EDT
The footnote was inheriting it's font colour from the block containg the
footnote reference. Since these footnotes originated in a block with white text
the footnote was invisible.

Hardcoded the footnote font to black since footnotes will always be on a white
background.

Note You need to log in before you can comment on or make changes to this bug.