Bug 446020 - gtk-doc scan failed on libanjuta
gtk-doc scan failed on libanjuta
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anjuta (Show other bugs)
9
ia64 Linux
low Severity low
: ---
: ---
Assigned To: Debarshi Ray
Fedora Extras Quality Assurance
:
Depends On:
Blocks: fedora-ia64
  Show dependency treegraph
 
Reported: 2008-05-12 01:57 EDT by Zhan, Yi
Modified: 2008-05-14 07:01 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-13 23:02:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
fix gtk-doc scan build failed (570 bytes, patch)
2008-05-12 01:57 EDT, Zhan, Yi
no flags Details | Diff

  None (edit)
Description Zhan, Yi 2008-05-12 01:57:45 EDT
Description of problem:

This was seen when trying to build anjuta on fedora ia64. Below warning was seen
when compiling libanjuta-scanner:

libanjuta-scan.c: In function 'get_object_types':
libanjuta-scan.c:26: warning: implicit declaration of function
'anjuta_plugin_handle_get_type'

Then libanjuta-scanner failed with segfault when using
anjuta_plugin_handle_get_type. Full build log can be found at
http://ia64.koji.fedoraproject.org/koji/getfile?taskID=69798&name=build.log. 

The function anjuta_plugin_handle_get_type is defined in anjuta-plugin-handle.c
and declared in anjuta-plugin-handle.h. Adding anjuta-plugin-handle.h to
libanjuta.h could fix the build issue. Patch is attached. 

Version-Release number of selected component (if applicable):
anjuta-2.2.3-7.fc9

How reproducible:
always

Steps to Reproduce:
1. build anjuta-2.2.3-7.fc9 on ia64
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Zhan, Yi 2008-05-12 01:57:45 EDT
Created attachment 305081 [details]
fix gtk-doc scan build failed
Comment 2 Debarshi Ray 2008-05-13 23:01:09 EDT
Committed and tagged, but could not build due to a missing xulrunner dependency
in Rawhide. Thank you for the patch.
Comment 3 Bug Zapper 2008-05-14 07:01:13 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Note You need to log in before you can comment on or make changes to this bug.