Bug 446030 - blacs build failed on ia64 by trying to use /usr/lib64
blacs build failed on ia64 by trying to use /usr/lib64
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: blacs (Show other bugs)
rawhide
ia64 Linux
low Severity medium
: ---
: ---
Assigned To: Tom "spot" Callaway
Fedora Extras Quality Assurance
:
Depends On:
Blocks: fedora-ia64
  Show dependency treegraph
 
Reported: 2008-05-12 04:44 EDT by Zhan, Yi
Modified: 2008-05-13 12:46 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-13 12:46:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
fix lib64 issue on ia64 (333 bytes, patch)
2008-05-12 04:44 EDT, Zhan, Yi
no flags Details | Diff

  None (edit)
Description Zhan, Yi 2008-05-12 04:44:24 EDT
Description of problem:

When build blacs on fedora ia64 below error was seen:

gfortran  -o /builddir/build/BUILD/blacs/BLACS/TESTING/EXE/xFbtest_MPI-LINUX-0
blacstest.o btprim_MPI.o tools.o -L/builddir/build/BUILD/blacs/BLACS/LIB
-lmpiblacsF77init -lmpiblacs -lmpiblacsCinit -L/usr/lib64/lam -lmpi -llam
-llamf77mpi -ldl -lpthread -lutil
/usr/bin/ld: cannot find -lmpi
collect2: ld returned 1 exit status
make: *** [/builddir/build/BUILD/blacs/BLACS/TESTING/EXE/xFbtest_MPI-LINUX-0]
Error 1
error: Bad exit status from /var/tmp/rpm-tmp.30185 (%build)

The full log can be found at
http://ia64.koji.fedoraproject.org/koji/getfile?taskID=69400&name=build.log. 

The root cause is that "-L/usr/lib64/lam" was used to find the lam libs. Unlike
other 64 bit architectures, ia64 does not have /usr/lib and /usr/lib64 both, it
only has /usr/lib (since it only support 64 bit libs). So "/usr/lib/lam" should
be used here. 

Substituting '/lib64/' to '/lib/' in Bmak.inc.64bit for ia64 could fix the build
issue. Patch attached.

Version-Release number of selected component (if applicable):
blacs-1.1-26.fc9.1

How reproducible:
always

Steps to Reproduce:
1. buidl blacs under fedora ia64
2.
3.
  
Actual results:


Expected results:


Additional info:
I also tried to use Bmake.inc instead of Bmake.inc.64bit. It not worked, since
we still need to find lam header files under /usr/include/lam/64/ but Bmake.inc
specified /usr/include/lam/32.
Comment 1 Zhan, Yi 2008-05-12 04:44:24 EDT
Created attachment 305105 [details]
fix lib64 issue on ia64
Comment 2 Tom "spot" Callaway 2008-05-13 12:46:23 EDT
Fixed in F-9 and rawhide. I didn't trigger builds for this, but it is fixed in CVS.

(p.s. sed -i is your friend)

Note You need to log in before you can comment on or make changes to this bug.