Bug 446055 - applet doesn't wait for children
applet doesn't wait for children
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: system-config-printer (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F9Target
  Show dependency treegraph
 
Reported: 2008-05-12 09:17 EDT by Tim Waugh
Modified: 2008-07-26 02:09 EDT (History)
0 users

See Also:
Fixed In Version: 0.7.82.3-2.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-17 18:27:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Tim Waugh 2008-05-12 09:17:09 EDT
Description of problem:
When system-config-printer-applet launches system-config-printer (from the 'Find
Driver' button, for example), it doesn't wait for the process to finish or
collect its exit code.  This leaves a zombie.

Version-Release number of selected component (if applicable):
0.7.82.2-4.fc9
Comment 1 Fedora Update System 2008-05-13 11:21:54 EDT
system-config-printer-0.7.82.3-2.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update system-config-printer'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-3820
Comment 2 Bug Zapper 2008-05-14 07:02:19 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 Tim Waugh 2008-05-16 05:51:54 EDT
Works for me.
Comment 4 Fedora Update System 2008-05-17 18:27:09 EDT
system-config-printer-0.7.82.3-2.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 5 Fedora Update System 2008-07-26 02:09:44 EDT
system-config-printer-0.7.82.3-2.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.