Bug 446056 - Network connection is not enabled with DHCP or static IP
Network connection is not enabled with DHCP or static IP
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: dhcp (Show other bugs)
9
i386 Linux
low Severity low
: ---
: ---
Assigned To: David Cantrell
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-12 09:45 EDT by Kari Pietarinen
Modified: 2008-08-04 16:01 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-04 16:01:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Kari Pietarinen 2008-05-12 09:45:17 EDT
Description of problem:
Network connection is not enabled automatically with DHCP or static IP

Version-Release number of selected component (if applicable):
4.0.0-14.fc9

How reproducible:
Upgrade from Fedora 8 to Fedora 9 and boot PC. 

Steps to Reproduce:
1. Boot PC with Fedora 9 rawhide. PC gets an ip, network mask and default ip
gateway address. However, the network does not work.
2. Restart network services as root: '/etc/init.d/network restart'
information for eth0...dhclient(3433) is already running - exiting.

This version of ISC DHCP is based on the release available
on ftp.isc.org.  Features have been added and other changes
have been made to the base software release in order to make
it work better with this distribution.

Please report for this software via the Red Hat Bugzilla site:
    http://bugzilla.redhat.com

exiting.
 failed.
                                                           [FAILED]
3. Set ip as static manually: as root: '/etc/init.d/network stop'
'system-config-network
DHCP [*] -> DHCP [ ] and manual configuration

4. Restart network service as root:  '/etc/init.d/network start'
Bringing up loopback interface:                            [  OK  ]
Bringing up interface eth0:  RTNETLINK answers: File exists
Error adding address XXX.XXX.XX.XX for eth0.
RTNETLINK answers: Invalid argument
                                                           [  OK  ]
were XXX.XXX.XX.XX is actual ip address.
  
Actual results:
After configuring the ip address manually, the ssh does not as well mounting of
samba partitions is not possible.

Expected results:
Automatically configured working network services, ssh connections should be
working as well as mounting of samba disk partitions should be possible.

Additional info:
Comment 1 Bug Zapper 2008-05-14 07:02:26 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 David Cantrell 2008-06-23 10:42:27 EDT
Fedora 9 enables NetworkManager by default.  Some upgrade scenarios have left the 'network' service 
enabled and then enabled NetworkManager.  Make sure you only have NetworkManager -or- network 
enabled with chkconfig:

chkconfig NetworkManagerDispatcher on
chkconfig NetworkManager on
chkconfig network off

-or-

chkconfig NetworkManagerDispatcher off
chkconfig NetworkManager off
chkconfig network on

Once you take one of these paths, does networking work?
Comment 3 David Cantrell 2008-08-04 16:01:59 EDT
I cannot reproduce the problem described on a fresh F-9 system.  I believe you are experiencing problems with having both NetworkManager and the network service enabled.  Follow the suggestions in comment #2, and you should see things work again.

Note You need to log in before you can comment on or make changes to this bug.