Bug 446067 - gdmflexiserver starts new X server/session every time
gdmflexiserver starts new X server/session every time
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: gdm (Show other bugs)
9
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: jmccann
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-12 11:14 EDT by Reid Rivenburgh
Modified: 2015-01-14 18:21 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-16 16:30:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Reid Rivenburgh 2008-05-12 11:14:26 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9pre) Gecko/2008051120 Minefield/3.0pre

Description of problem:
On my desktop machine, I have one user, me, always logged in.  When not using the machine, I like to use gdmflexiserver to virtually "log out" so other users can login.  Running "gdmflexiserver", which I have associated with a panel application launcher in gnome, quickly shows the gdm greeter/login screen and then shows a new X server starting, followed several seconds later by another gdm greeter/login screen.  I can then enter my password to get back to my session.  If I run gdmflexiserver again, the process repeats.  Each time I do so, I get another metacity process (I don't even use metacity, which was a hint as to what was happening), as well as gdm-simple-slave and probably others.  It seems like gdm isn't reusing an existing sessions as I think it should.

After awhile, I start running into memory issues with all the associated sessions.  I'm not positive it's related, but I also get to the point where gdmflexiserver fails to start a new gdm login.  I suppose that should be a different bug, though.

I've been running rawhide since F9 alpha 1, and I don't remember this happening then.  It may be related to something I did to my system, but I can't think of what that might be.  I'm not sure how to debug this.


Version-Release number of selected component (if applicable):
gdm-2.22.0-1.fc9.x86_64

How reproducible:
Sometimes


Steps to Reproduce:
1.Login as a user from gdm.
2.Run gdmflexiserver from that session.
3.Relogin as the same user to get back to the session.
3.Run gdmflexiserver again.

Actual Results:
I get a new gdm session for each gdmflexiserver.

Expected Results:
I think it should reuse the existing gdm session.

Additional info:
Comment 1 Bug Zapper 2008-05-14 07:02:46 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 Reid Rivenburgh 2008-05-16 16:30:32 EDT
Here's some additional info:  I don't see this problem either as root or another
regular user on my system, only with my account.  It's likely that this is
something specific to me, though I wish I knew what....  I'll change this to
NOTABUG since it likely isn't.

Note You need to log in before you can comment on or make changes to this bug.