Bug 446092 - xmlto txt target does not work
Summary: xmlto txt target does not work
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: xmlto   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ondrej Vasik
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-05-12 18:05 UTC by Paul W. Frields
Modified: 2008-05-14 22:13 UTC (History)
0 users

Fixed In Version: xmlto-0.0.20-3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-13 10:23:40 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Paul W. Frields 2008-05-12 18:05:09 UTC
Version/release: xmlto-0.0.20-2.fc9.x86_64

If I run 'xmlto txt some-doc.xml' on a properly validated DocBook XML 4.4
document, the resulting text is ugly.  It looks like xmlto is trying to run 'w3m
-dump' directly on the XML file instead of transforming it to HTML-nochunks
first and then running w3m against that .html file.  This borked the
README-BURNING-ISOS file that's in our release notes for Fedora 9.  The sooner
we can get an update, the better! :-)

Comment 1 Ondrej Vasik 2008-05-13 10:23:40 UTC
Thanks for report, ugly one-liner :( (forgot to export backend for stylesheet
section when adding FOP). Fixed in xmlto-0.0.20-3 , built in koji
http://koji.fedoraproject.org/koji/taskinfo?taskID=606790 . 

Comment 2 Fedora Update System 2008-05-13 10:38:38 UTC
xmlto-0.0.20-3.fc9 has been submitted as an update for Fedora 9

Comment 3 Fedora Update System 2008-05-14 22:13:03 UTC
xmlto-0.0.20-3.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.