This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 446104 - Postgres may not be fully started when the service script returns
Postgres may not be fully started when the service script returns
Status: CLOSED CURRENTRELEASE
Product: Virtualization Tools
Classification: Community
Component: ovirt-server-suite (Show other bugs)
unspecified
All Linux
low Severity low
: ---
: ---
Assigned To: Alan Pevec
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-12 15:00 EDT by Benjamin Kahn
Modified: 2010-03-16 13:13 EDT (History)
1 user (show)

See Also:
Fixed In Version: 0.0.5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-02 10:42:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Benjamin Kahn 2008-05-12 15:00:14 EDT
Description of problem:
Postgres may not be fully started when the service script returns.
This causes problems with the wui install scripts since they assume they can
start running database commands right away.

Version-Release number of selected component (if applicable):
ovirt-wui-0.0.4-2.fc8

How reproducible:
Happens every time on my machine, but likely won't happen on faster machines, or
machines with more RAM

Steps to Reproduce:
1.Run the wui first boot script
  
Actual results:
ovirt database doesn't get created

Expected results:
Database created

Additional info:
Putting a "sleep 2" in the startup script fixes the problem on my box, but there
should be a better way to ensure the database is actually started.
Comment 1 Alan Pevec 2008-05-12 18:05:55 EDT
indeed, postmaster is started in the background, so we'll need to loop after
service postgresql start, waiting for service postgresql status to return 0

Note You need to log in before you can comment on or make changes to this bug.